[PD] Rép : PDGST - no pix_gst2pix... and building Gem 0.93 with mac OS 10.6

x.garnier x.garnier at orange.fr
Fri Nov 4 19:34:02 CET 2011

Good evening,
I've downloaded Gem 0.93.1 but I didn't succeed in installing it.
I've tried to :

- download the last version of pd-extended but it's 0.42.5 and it's mine (which also means that I have Gem 0.92).

- get some informations here : http://gem.iem.at/documentation/faq/how-do-you-compile-gem-on-osx and then :

- use build/osx-xcode but I don't know what to do inside Xcode as I have a lot of files in red (missing ?) and I've never tried to "build and run" with Xcode before (I'm no developer at all unfortunately) ...

- build Gem in /Applications/Pd-extended.app/Contents/Resources/extra/Gem-0.93.1 with :

./configure --disable-dependency-tracking --enable-fat-binary=ppc,i386 PKG_FTGL_CFLAGS="-I/usr/local/include/FTGL $(freetype-config --cflags)" PKG_FTGL_LIBS="-L/usr/local/lib/ -lftgl -lfreetype"

which is the command you advise to use.
but then I get this message :
 Install path           : /usr/local

  version                : 0.0
  extension              : pd_darwin

 used optional libraries:

  font-rendering         : FTGL

    use ImageMagick      : no
    use TIFF             : no
    use JPEG             : no
    use PLUGINS		 : yes
    use mpeg             : no
    use mpeg-3           : no
    use QuickTime        : yes (framework)
    use aviplay          : no
    use gmerlin          : no
    use PLUGINS		 : yes
    use v4l              : no
    use v4l2             : no
    use ieee1394         : no

configure: error: Pd (header) is mandatory and seems to be missing!
I don't actually have any folder named Pd (exept an alias), only pdextended, I've tried to build Gem 0.93.1 in several locations but I get that same message all the time...
I'm sorry that must be a stupid problem but if could give me some hints to try to install Gem 0.93.1 (do I have do delete Gem 0.92 by the way ? how if needed ?), I hope I'll be able to reinstall pdgst with the gst2pix object this time...
thanks a lot


Hash: SHA1

On 2011-10-31 00:37, x.garnier wrote:
> Hello you all, 

> pix_gst2pix.cpp:148: error: ?class GemState? has no member named ?set?
> pix_gst2pix.cpp:148: error: ?_PIX? is not a member of ?GemState?

it seems like you are trying to compile pdgst with an older version
(<0.93) of Gem.
it also seems like pdgst currently only builds with Gem>=0.93

i hope i find time to make pdgst backward compatible.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20111104/00e89d4e/attachment.htm>

More information about the Pd-list mailing list