[PD] Escape characters appear in message after rebooting patch

Boris borisaccount at gmail.com
Sun Nov 6 19:54:08 CET 2011


I'm making an abstraction to make it easier to record audio to .wav. Everything is fine with that, until I copy the abstraction and use it twice in the same patch, because I use sends in the abstraction. This I fixed by making all sends like [send $0-startrecording] etc. This works fine. 

The only problem I have is with the Start/Stop button. I made a button that when clicked changes from Start to Stop. The color changes (from red to grey), and the send-symbol also changes. I used to do this by sending a message with 'send stop' to it. But since I now want to be able to use the recording abstraction more than once in a patch, I had to change this to 'send $0-stop'. And this doesn't work :-(

It changes the send value of my start/stop button, but it doesn't change it to $0-stop. It changes it to 0-stop, without the dollar sign. So the first thing I tried was to change the message to 'send \$0-stop', but escape characters aren't allowed. I tried some more stuff, and after a while I tried 'send $$0-stop'. This works perfectly!

Until I reboot the patch.

The message is then surprisingly changed to 'send $\$0-stop'. I thought escape characters weren't allowed!!!

Anyway, this translates to the following send-symbol in my start/stop button: $#0-stop

I think this is a bug? So that's why I'm e-mailing this, maybe you can do something with it.

If you open the attached test.pd, you'll see how my record abstraction looks. You can then open it, and you will see a lot of 'send $0-xxx' things there. If you open the 'stopknop' patch you'll see where the problem is. I'm sorry the patches are in Dutch but you should be ok.



-------------- next part --------------
A non-text attachment was scrubbed...
Name: schrijf~.pd
Type: application/octet-stream
Size: 7693 bytes
Desc: not available
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20111106/e84a917a/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test.pd
Type: application/octet-stream
Size: 132 bytes
Desc: not available
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20111106/e84a917a/attachment-0001.obj>

More information about the Pd-list mailing list