[PD] new object: [path] - following the example of [import]

Mathieu Bouchard matju at artengine.ca
Thu Dec 1 21:50:38 CET 2011

Le 2011-12-01 à 11:34:00, Hans-Christoph Steiner a écrit :
> On Dec 1, 2011, at 5:45 AM, IOhannes m zmoelnig wrote:
>> #1 do you think "path" is a good name, or will people confuse that with
>> "getdir"? probably [searchpath] would be more meaningful.
> I'm not stuck on the name 'path', but I do insist on consistency.  The 
> prefs are called "Path...", the [declare] flag is called -path, and the 
> command line arg is called -path.

the C interface to the path is named «sys_searchpath». I suppose that this 
is where Johannes got his idea from.

I'm not advocating for it though. It's best to stick with what the user 
knows when there are no reasons to do it otherwise. There are often 
reasons to do it otherwise, but this doesn't seem like one.

| Mathieu BOUCHARD ----- téléphone : +1.514.383.3801 ----- Montréal, QC

More information about the Pd-list mailing list