[PD] autocompletion bug report

yvan volochine yvan.pd at gmail.com
Thu Dec 29 17:11:18 CET 2011

On 12/28/2011 11:59 PM, olivier gailly wrote:
> hello,
> this plugin seems great but i have a problem installing it :
> UNHANDLED ERROR: version conflict for package "Tcl": have 8.4, need 8.5
>      while executing
> "package require Tcl 8.5"
>      ("uplevel" body line 27)
>      invoked from within
> "uplevel #0 $tclcode"
> FAILED TO LOAD /Users/oliviergailly/Library/Pd/completion-plugin.tcl
> i have updated tcl and tk :
> The following ports are currently installed:
>    tcl @8.5.11_0 (active)
> i have tested various versions of pd, none are working. ( now i use vanilla 43, the last released version, i have also checked with expended)
> only an old version of the plug is working : alpha0.32
> i have read somewhere in tha mail archive :
> OSX note:
>>> there are some focus problems with tcl8.5 (x11), but not with tcl8.5 built
>>> with aqua support.
> is it the solution ? (if it is i need a quick tuto because i dont understand the whole thing...)
> im using OSX. 10.6.8 32bit,
> so if you have a suggestion for me...

hi Olivier

thanks for reporting this (I post it to pd-list as well as it might be 
of interest for others)

it seems you have several tcl installed together and the first one found 
is 8.4.
in a tclsh shell, what does the following line outputs?
`puts $tcl_version'

alas I don't have access to any osx machine right now but IIRC I got it 
working on a mac by installing active-tcl and manually installing tclsh 
that came alongside but I'm not 100% sure.

maybe some other osx users can give you more help ?

in any case good luck,

yvan.volochine at gmail.com

More information about the Pd-list mailing list