[PD] 0.43 Audio problems > trying Pd-0.42.5-extended on Ubuntu Oneiric ?

Hans-Christoph Steiner hans at at.or.at
Wed Jan 25 03:35:39 CET 2012

On Jan 24, 2012, at 6:07 PM, tim vets wrote:

> Hi all,
> I tried Pd-extended 0.43 on Oneiric but I can't get audio working with it 
> (both Jack and alsa, broken sound, very slow, hangs and crashes...)

Strange, it works on my Oneiric, that's my main dev OS.  I have had a bunch of other problems with Oneiric, its pretty rough.

> I have another disk which also runs Oneiric, and it has Pd-Extended 0.42.5 running nicely, 
> so I want to try 0.42.5 on this install too, to see if the sound problem goes away.
> I don't remember how I got in on the other Oneiric, did the Maverick .deb work on Oneiric before? now it says 'dependency not satisfiable: libquicktime2...
> (It may be that I installed it on Natty, and upgraded that to Oneiric afterwards...)
> I also tried dpkg --force-depends --install ./Pd-0.42.5-extended-ubuntu-maverick-i386.deb
> but then I got a pd-extended that can't load any of the externals.

You can download the dependencies from older Ubuntu distros if you are using a build for an older distro.  Check out http://packages.ubuntu.com

If you got it installed with --force-depends, it should run.  libquicktime is only needed for pdp/pidip.

> Trying to build it from source, 
> with Pd-0.42.5-extended/scripts/auto-build/pd-extended-auto-builder.sh  but I keep running into this:
> ./configure: line 5787: syntax error near unexpected token `SINF,'
> ./configure: line 5787: `AST_EXT_LIB_CHECK(SINF,   m, sinf)'
> make[1]: [pd] Error 2 (ignored)
> as far as i know I installed all dependencies...

I think you are missing one of these:

sudo apt-get install autoconf automake libtool



If you are not part of the solution, you are part of the problem.

More information about the Pd-list mailing list