[PD] hid object does not work for wacom tablet under Linux

Sylvain Hanneton sylvain.hanneton at laposte.net
Sun Feb 19 20:22:21 CET 2012


I used the last input-wacom driver :
insmod /home/.../input-wacom-0.12.1/2.6.30/wacom.ko
When loaded it creates  /dev/input/event14  and a /dev/input/wacom entries
I ran pd with sudo.
I tested the HID object with the example of the documentation. The 
"info" message displayed correctly the properties of the tablet.
However, when I tried to use the polling function, nothing happened.

On 19/02/2012 18:42, IOhannes m zmölnig wrote:
> On 02/18/12 20:36, Hans-Christoph Steiner wrote:
>> [hid] on Linux relies on a /dev/input/event* devices.  If that device 
>> does not provide a /dev/input/event* device, then [hid] can't read 
>> it.  One possibility is that you are using an X driver for that 
>> tablet, so not a /dev/input/event* device.
> another possibility is, that you don't have read permissions for the 
> /dev/input/eventX device (that points to your wacom tablet)
> gfmasfrt
> IOhannes
> _______________________________________________
> Pd-list at iem.at mailing list
> UNSUBSCRIBE and account-management -> 
> http://lists.puredata.info/listinfo/pd-list

More information about the Pd-list mailing list