[PD] trying to track down a bug: Pd-extended 0.43-1 beta on Oneric 32 bit

John Harrison johnharrisonwsu at gmail.com
Thu Mar 29 19:03:08 CEST 2012

I've been trying to track down a seg fault I keep getting and I'm still not
sure if the problem is Gem or Pd-extended or what.

This is the latest pd-extended 0.43.1 Beta CVS March 29 (today) running on
Oneric 32 but. I have simplified my patch to a point it doesn't make sense
anymore but I can still make it crash, so I figure that's what we need.

Basically if you create a new patch then make the object [test99 1], then
copy and paste that object, then change the 1 parameter to a 2 you get a
seg fault most of the time. If not, creating a [test99 3] or [test99 4]
should do it, again most of the time.

It seems related with Gem but I'm not sure if it is a Gem bug. I tried the
same Gem library with Pd vanilla and it didn't crash. On the other hand, it
seems related to the [pix_image] object in test99. Also you need to have
the parameters to get the patch to crash, even though the patch doesn't
take parameters. (The original patch did take parameters.)

Core dump has only this information: Program terminated with signal 11,
Segmentation fault.
#0  0x0111ac01 in gem::RTE::Outlet::send(std::string, std::vector<gem::any,
std::allocator<gem::any> >) () from

[test99] is attached.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20120329/aa85af5c/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test99.pd
Type: application/octet-stream
Size: 152 bytes
Desc: not available
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20120329/aa85af5c/attachment.obj>

More information about the Pd-list mailing list