[PD] nanoKontrol2 dropping MIDI messages (OSX)

Ángel Faraldo angelfaraldo at gmail.com
Sat Jun 16 22:11:02 CEST 2012


thanks for your quick reply, Miller.

On Jun 16, 2012, at 9:39 PM, Miller Puckette wrote:

> Hi Ángel -
> I've seen a similar problem reported in Windows:
> http://lists.puredata.info/pipermail/pd-list/2012-02/094794.html
> and tried to recreate it with no success.  I think the Max problem you
> found is something different (because at least there the values settle
> correctly when the sliders stop moving while for you it seems like something
> is ending up in the wrong state).


> Anyway, with apologies I have to say I'm delighted you can get this to
> happen on a Mac - if indeed it's the same problem as on the PC it means
> it's in teh Pd code and so if I can ever get it to happen here I can probably
> fix it :)

I'm glad you're delighted, specially if a fix can come out of it.

thanks again!


> Miller
> On Sat, Jun 16, 2012 at 07:24:09PM +0200, Ángel Faraldo wrote:
>> Hi list, 
>> Yesterday I bought a new korg nanoKontrol2. To my surprise, after a few basic testings, i've discovered that when I move as little as three faders sending CC values simultaneously --and not incredibly fast--, pd doesn't receive a big part of the values (with [ctlin]), staying half the way in the midi-value range.
>> ---------For example, moving three faders from minimum to maximum, that is, from 0 to 127, the values in the number boxes connected to [ctlin] end up in random numbers in between (like 63, 74 and 70). Even more weird (or maybe not!) is that when I move any of the faders again, the next value that is thrown out is 126 (as if the object had actually gotten the previous 127 and is going down from there!)---------
>> Indeed, using a midi monitoring program ('MIDI monitor' on my mac), I can see that the computer receives all the midi values as expected, so I guess that something happens on the [ctlin] level in Pd.
>> Apparently this is/was also an issue on Max's implementation of [ctlin]: http://cycling74.com/forums/topic.php?id=19562
>> I have worked with other Midi controllers in Pd and I never had a similar problem.
>> i've also tried [midiin]->[midiparse], with exactly the same results.
>> (mac osx 10.6.8, pd-extended 0.42.5, pd-extended 0.43.1, pd 0.43.2)
>> any light on this??
>> cheers,
>> Ángel Faraldo
>> _________________
>> www.angelfaraldo.info
>> _______________________________________________
>> Pd-list at iem.at mailing list
>> UNSUBSCRIBE and account-management -> http://lists.puredata.info/listinfo/pd-list

Ángel Faraldo

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20120616/a7bec453/attachment.htm>

More information about the Pd-list mailing list