[PD] array size (was Re: arraysize)

IOhannes m zmölnig zmoelnig at iem.at
Fri Sep 28 10:00:44 CEST 2012

On 09/28/2012 02:01 AM, Miller Puckette wrote:
> Hmm... I agree there's bad confusion between array and table in Pd
> nomenclature.  I've tried to use "table" for a specifically floating-point
> array, and "array" for the more general thing, but I think I've been
> less than consistent (case in point, the "array" menu which creates what
> I would call a "table".
> One idea might be to use the name [tab] instead of [array], as in 
> [tab size] - then [tabwrite] could get a synonym, [tab write], etc.

i'm quite with hans here: what exactly do we gain from having an object
[tab write], instead of [tabwrite]?
and i totally fail to see how [tab size] is superior to [tabsize].

in terms of remembering the names, they see quite on par;
it is made clear that those objects belong to the same family regardless
of whether the prefix is "tab" "tab " or "tab_", as long as there is a
common short prefix;
in terms of typing there is one more character to type;
and from the implementation side, it needlessly compilates the
object-lookup mechanism, as can be seen in the current implementation of
the "list" family of objects (where the objectcreator is made aware of
an object named "list\ size", but this object is practically never
requested from the objectmaker, and instead the constructor function of
"list" has to re-implement the dispatching.

it's not that "foo bar" is bad by itself; i just don't see that it is
anywhere better than what we already have.


More information about the Pd-list mailing list