[PD] Xth sense on archlinux

Marco Donnarumma devel at thesaddj.com
Thu May 9 16:23:54 CEST 2013

Hi Fero,

(I replied also on the linux audio list, but I copy the reply below)

the errors you reported happens only with the new pd-extended 43.4; that
is, with pdx 42.5 everything works fine.

In the latest pdx release, the object [line3] and the library in which it
was included have been removed. These were not maintained by me. So I
compiled binaries for Linux ubuntu and mac and included them in the

You can find line3 source here:

simply compile it and add it to the xth-sense-lib.

As for the second error, that is a general Pdx bug, apparently related to
GOP (graph on parent) objects. I managed to isolate it and submit a report,
but it has to be solved yet.

When did you downloaded the Xth Sense software? Very recently I updated the
XS software to a new version which seemed to have worked well against this

it would be great if you could test it out, if you have an older version.

on a side note, I'm in the process of updating the documentation and the
software to version 2.0, but I've been slowed down by the above issues
appeared with pdx 43.4. So, hopefully soon this issues should be addressed
adequately and documented.

hope this helps!

Marco Donnarumma
New Media + Sonic Arts Practitioner, Performer, Teacher, Director.
Embodied Audio-Visual Interaction Research Team.
Department of Computing, Goldsmiths University of London
Portfolio: http://marcodonnarumma.com
Research: http://res.marcodonnarumma.com
Director: http://www.liveperformersmeeting.net

Hallo list,
> Was anybody successful to run Xth sense software (based on pd) on archlinux
> ?
> pdx 0.43.4
> Where I see problems is th 64 bit incompatibility with the xth sense libs,
> which are precompiled:
> pd-externals/xth-sense-lib/line3.pd_linux:
> /home/paum/pd-externals/xth-sense-lib/line3.pd_linux: wrong ELF class:
> and TCL errors like this:
> (Tcl) INVALID COMMAND NAME: invalid command name ".x7f4e941406b0.c"
>     while executing
> ".x7f4e941406b0.c create image 901 776 -image 7f4e94924050PHOTOIMAGE -tags
> 7f4e94924050PHOTO"
>     ("uplevel" body line 929)
>     invoked from within
> "uplevel #0 $cmds_from_pd"
> thanks for reply
> --
> Fero Kiraly
> www.ferokiraly.com
> www.cluster-ensemble.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20130509/1b4fac33/attachment.htm>

More information about the Pd-list mailing list