[PD] l2ork: SSSAD loads but doesn't save presets

András Murányi muranyia at gmail.com
Wed Jul 3 20:34:31 CEST 2013

On Mon, Jun 24, 2013 at 7:04 PM, Frank Barknecht <fbar at footils.org> wrote:

> On Mon, Jun 24, 2013 at 04:00:15PM +0200, András Murányi wrote:
> > thanks for the tip.
> > I'm using [presetstore] which writes to [pd presetstore0] (etc...)
> > subpatches. (BTW, latest s-abstractions don't have [presetstore] any
> more?)
> > I've set up the print on receivers, but I guess placing [r
> > and [r $2-SSSAD] inside the [presetstore] patch was not a good idea
> because
> > they didn't receive anything (where to put them then?)
> sssad-objects created as [sssad something KEY] will send to
> KEY-SSSAD, all others will send to SSSAD_ADMIN and SSSAD. To receive from
> those
> semi-global [sssad]-objects, you'd need to replace the receivers next to
> the
> sssad-objects that use the second argument.
> Maybe you can search for "sssad" objects in your patch and try to find some
> that use second args?
> Also the semi-global/local receivers have been added at some time after
> s-abstractions where born. Although old already, maybe you have a mix of
> both
> versions installed now? The old one didn't have any $2-SSSAD
> senders/receivers
> inside.
> Ciao
> --
>  Frank Barknecht                                     _ ______footils.org__

Shame on me, i did have two different sssad folders in my path. Now i've
cleaned things up and there's only the one from s-abstractions - but that's
not the solution yet.
I've noticed that s-abstractions dropped [presetstore] and that may have a
good reason. Is it possible that it's actually not compatible with current
I've also noticed [saver] in s-abstrations/sssad which seems to be like
[presetstore] (except that [presetstore] saved to subpatches while [saver]
saves to textfiles). I've tried it and it doesn't work for me: "error:
$1state-11.sssad: write failed". (It does create 0-byte files in
s-abstrations/sssad though.)

[datastore] however, is still part of s-abstractions (it saves a single
state to a subpatch), and it doesn't work here. I tried datastore-help.pd
and it saves an empty state. What's interesting, is that if I try it while
my other big patch is open, it consistently triggers a segfault.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20130703/4d21a89c/attachment.htm>

More information about the Pd-list mailing list