[PD] udoo board sound issues

Dan Wilcox danomatika at gmail.com
Tue Mar 11 15:14:08 CET 2014

Heres a trim of my notes:

Enable realtime audio priority (if you haven't done it already):

	sudo su -c 'echo @audio - rtprio 99 >> /etc/security/limits.conf'
 	sudo su -c 'echo @audio - memlock 250000 >> /etc/security/limits.conf'
 	sudo su -c 'echo @audio - nice -10 >> /etc/security/limits.conf'

I disable pulseaudio. Make sure pulseaudio does not respawn itself (from http://voices.canonical.com/david.henningsson/2012/07/13/top-five-wrong-ways-to-fix-your-audio):

    echo autospawn=no > ~/.pulse/client.conf

Also add the following to ~/.bash_login to kill pulse audio if it's running on login:

    # kill pulse audio if it was spawned
    pulseaudio -k

I'm not looking at the udoo run script, but I'm pretty sure I'm using the following with the US-25EX USB soudcard:

pd -rt -nogui -alsa -audiodev 5

Use pd -listdev to get the device list from alsa. I chose 5 as the first 4 (from memory) are 1-2 (built in hardware & plugin) & 2-3 (HDMI audio hardware & plugin). 5 is the USB hardware alsa dev.

On Mar 11, 2014, at 4:05 AM, Simon Iten <itensimon at gmail.com> wrote:

> without jack i should add...
> On 11 Mar 2014, at 08:55, Simon Iten <itensimon at gmail.com> wrote:
>> hey dan,
>> unfortunately i’m in switzerland :-)
>> would be great if you could post your setup somewhere or send the infos! i compiled pd from source as well. i start it from console (with -rt) and it works without problems with the builtin sound card. maybe the cheap card from dx.com just does not work properly with udoo.
>> but please post your setup.
>> thanks
>> On 09 Mar 2014, at 22:26, Dan Wilcox <danomatika at gmail.com> wrote:
>>> I've tried my both Roland Edirol UA-25 & UA-25EX and both work great. The dedicated USB controller makes these guys work as compared to an RPI where I can't get full duplex without tons of dropouts. I'm using a Linaro install which boots to the console and runs the PD through scripting. The speed is great as compared to my old wearable computer. 4 cores makes a difference.
>>> I had to recompile my kernel to add midi support, but that's working great. It's not too bad, actually. I also built Pd-vanilal from source which was pretty easy using ./configure + make. I also have a script which fetches externals and builds/installs the agains vanilla so I have the few externals I need.
>>> As with my previous experience running Pd + embedded Ubuntu, I get great performance with RT permissions, the -rt startup flag, and ALSA. Jack is needless overheard unless you want to work with other Jack-enabeld apps. Same with X windows, although my setup was running great in X with pd + ALSA in testing.
>>> From your description, it sounds like your main issue is jack & pd are probably not running in realtime.
>>> I can sent you my install notes if you want (or put them online, as I've been meaning to). Also, are based in the NE within driving distance to Pittsburgh? We could do a patching circle/UDOO setup afternoon :D
>>> On Mar 9, 2014, at 5:14 PM, pd-list-request at iem.at wrote:
>>>> From: Miller Puckette <msp at ucsd.edu>
>>>> Subject: Re: [PD] udoo board sound issues
>>>> Date: March 9, 2014 at 5:07:54 PM EDT
>>>> To: Simon Iten <itensimon at gmail.com>
>>>> Cc: PD list <pd-list at iem.at>
>>>> H iSimon -
>>>> I haven't tried any but the built-in yet but I have a few USB interfaces
>>>> around here that I can try.  I'm about to go on an intense trip but should
>>>> be able to do some tests when I get back, assuming nobody else has figured
>>>> this out first.
>>>> cheers
>>>> Miller
>>>> On Sun, Mar 09, 2014 at 09:57:45PM +0100, Simon Iten wrote:
>>>>> hey list,
>>>>> does anybody that uses an udoo board have any recommendations on a usb-soundcard? should be very compact.
>>>>> i tried a cheap one from dx and i could not get any good results (loads of xruns even with periods 3 and 1024 and up frames in qjackctl) this is on the ubuntu version from udoo.
>>>>> are there some tweaks i can do to improve usb-sound capabilities? i thought maybe recompile the kernel with only usb-1 support since there is no option as on the pi to disable usb-2 via config, or am i missing something?
>>>>> is it better to use the usb-soundcard without jack (pd does not like the usb-soundcard either when i tried briefly)?
>>>>> the internal sound-input is to noisy for my application (guitar effect)
>>>>> cheers. 
>>>>> _______________________________________________
>>>>> Pd-list at iem.at mailing list
>>>>> UNSUBSCRIBE and account-management -> http://lists.puredata.info/listinfo/pd-list
>>> --------
>>> Dan Wilcox
>>> @danomatika
>>> danomatika.com
>>> robotcowboy.com

Dan Wilcox

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20140311/48d2156f/attachment.htm>

More information about the Pd-list mailing list