[PD] UDOO Quad and Generic Guitar to USB link issues

Carlos Sanchez csanchez126 at gmail.com
Sun Apr 6 20:37:44 CEST 2014

Hey list,

Thanks for your prompt replies and helpfulness!

I could not get qjackctl to work, the audio will not go through and the PD
CPU load gets abnormally high at around 67%...
I had already played with the sample rate and I had noticed that augmenting
the frequency yields better results but the noise was still very present.
The sound card itself works correctly with Audacity so I am sure it would
work with the arecord and aplay commands Brian suggested. Weirdly, it is
only with PD that it is struggling...

On a more encouraging note, as Brian suggested, it seems that the problem
(or one possibility) is the duplex audio. I haven't thought about using the
card as an output only device before and it did work! But afterwards, I was
not able to change the settings back and use the noisy duplex audio any
more, I was only able to switch the output devices...

@Brian: What type of software are you using for the signal processing with
the Raspberry Pi? I am very curious because I had first attempted to build
this project on a BeagleBone Black but the heavy PD patches made it
unstable or crash...

On Sat, Apr 5, 2014 at 12:16 PM, Brian Fay <ovaltinevortex at gmail.com> wrote:

> If you haven't tried it already, try increasing the latency in the audio
> settings (probably not the issue, but worth a shot).
> Maybe it's only having trouble with duplex audio (simultaneous input and
> output). Do you have both input and output enabled for your soundcard? Does
> it work if you only have the output device set, and leave the input device
> blank?
> You can test to see if duplex audio is working outside of pd - try running
> "arecord | aplay" (the vertical bar means pipe the data from arecord into
> aplay), and see if you get usable sound. You may need to set some command
> line flags on those to get the sample rate and audio devices right, sorry I
> don't know them offhand.
> I am running a fairly similar setup - for an honors project at my
> university, I'm using a Raspberry Pi and Behringer UCG102. I have a nice
> multi-effects pedal working at less than 20ms latency. If my Raspberry Pi
> can handle it, I feel like your UDOO quad should definitely be able to. I'd
> like to add that you have a nice taste in projects :)
> On Fri, Apr 4, 2014 at 10:41 AM, Carlos Sanchez <csanchez126 at gmail.com>wrote:
>> Yes, I have tried changing sample rates and it has not solved the issue.
>> The sound card I am using is basically a copy of the Behringer UCG102
>> guitar to USB interface :
>> http://www.behringer.com/EN/Products/UCG102.aspx
>> On Fri, Apr 4, 2014 at 8:40 AM, tim vets <timvets at gmail.com> wrote:
>>> and what is this 'Generic Guitar to USB' exactly?
>>> 2014-04-04 3:09 GMT+02:00 Carlos Sanchez <csanchez126 at gmail.com>:
>>>> Hello PD-list,
>>>> I am currently working on my semester project which is a guitar
>>>> multi-effect pedal using the UDOO Quad and PD. I got everything up and
>>>> running on the Linaro Ubutu 12.04 LTS build provided by UDOO and I am
>>>> having strange results with PD. The soundcard I am using works normally
>>>> when I am using Audacity. It plays wav files and can record the guitar
>>>> signal correctly but when it comes to PD, a basic osc object or a table
>>>> read through ALSA produces a strange digital noise, completely ruining the
>>>> audio signal.
>>>> I have also tested this setup with a M-Audio Fast Track Pro USB card
>>>> and the playback worked without issues, although I could not get the input
>>>> signal through the adc object for an unknown reason.
>>>> Has anyone tried a similar setup for guitar usage?
>>>> Thanks!
>>>> _______________________________________________
>>>> Pd-list at iem.at mailing list
>>>> UNSUBSCRIBE and account-management ->
>>>> http://lists.puredata.info/listinfo/pd-list
>> _______________________________________________
>> Pd-list at iem.at mailing list
>> UNSUBSCRIBE and account-management ->
>> http://lists.puredata.info/listinfo/pd-list
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20140406/0ff15745/attachment.htm>

More information about the Pd-list mailing list