[PD] 64bit runtime error 'couldn't read file "/usr/tcl//pd-gui.tcl"'

IOhannes m zmölnig zmoelnig at iem.at
Wed Apr 9 12:29:27 CEST 2014

On 04/09/2014 11:57 AM, David Woodfall wrote:
>> But that doesn't mean that pd will look there for modules.
>> I tried symlinking /usr/lib64/pd/tcl/pd_connect.tcl to /usr/bin/.
>> but it still doesn't find it.

no this won't work, as it tries to circumvent tcl's pkg-index.

>> pd-gui.tcl
>> Error in startup script: can't find package pd_connect
>>   while executing
>> "package require pd_connect"
>>   (file "/usr/bin/pd-gui.tcl" line 26)
>> I'm not quite sure where it is define where to look.
> Aha! If I 'ln -s /usr/lib64/pd /usr/lib/pd' then it works. Gui starts
> up just fine. So it seems those paths may be hard-coded somewhere.

well yes, that's why i gave you the patch in my other mail: replace
lib/pd by lib64/pd in s_main.c


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 880 bytes
Desc: OpenPGP digital signature
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20140409/96db6f11/attachment.pgp>

More information about the Pd-list mailing list