[PD] UDOO Quad and Generic Guitar to USB link issues

Carlos Sanchez csanchez126 at gmail.com
Fri Apr 11 01:54:15 CEST 2014

Neat project sir!

I have tried what you mentioned Brian and I cant get the system to even
play sounds with the right device. Using aplay file.wav works with the
default output but when i try to specify the output like so "aplay -D
hwplug;2,0 file.wav" nothing comes up. I got these commands somewhere on
the net, can you vouch for them? Also, when listing the devices with
alsamixer, my soundcard lists a mic input which is odd since it has a mono
in and stereo out...

If this is of any use, here is the output of aplay -l:

**** List of PLAYBACK Hardware Devices ****
card 0: vt1613audio [vt1613-audio], device 0: HiFi vt1613-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: imxhdmisoc [imx-hdmi-soc], device 0: IMX HDMI TX mxc-hdmi-soc-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Device [USB PnP Sound Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

My soundcard is the card 2 and I can not get any sound out of it via aplay!

On Tue, Apr 8, 2014 at 5:26 PM, Brian Fay <ovaltinevortex at gmail.com> wrote:

> The reason I suggested trying "arecord | aplay" is because it would be
> running input and output simultaneously. In Audacity, you're doing one
> after the other.
> Unfortunately, I'm not sure exactly what is going wrong here. Does your
> soundcard work as expected on other computers? Was it fine on the
> BeagleBone Black?
> On the Raspberry Pi, I'm running a multi-effects pedal, all built in Pd.
> There's two parallel chains of processes, (each can run up to eight
> effects). The effects I'm using are a looper, delay, waveshaper distortion,
> flanger, granular synthesis (sort of limited implementation), reverb, and
> EQ. I'm controlling things with a QuNeo MIDI controller and a push button
> attached to the GPIO pins on the Pi.
> By default, each of the eight effects in each chain are set to "bypass,"
> which simply passes the signal onto the next effect. However, you can
> adjust this on the fly for the effects to be whatever you want, so I can
> set up something like:
> Chain A: looper -> distortion -> flanger -> delay -> granular -> reverb ->
> EQ -> bypass -> output
> Chain B: delay -> bypass -> bypass -> bypass -> bypass -> bypass -> bypass
> -> bypass -> output
> I can independently control volume of each chain, so I could use Chain A
> to build up some sort of droning ambience, and then solo over it using
> Chain B.
> In practice, there is definitely a limit to the ability of the Raspberry
> Pi. I think the example I just mentioned would probably run, but if I try
> throwing too many effects on at once, (flanger, reverb, distortion, and
> granular are all pretty intensive), I will start getting glitches - huge
> crackles and jitters in audio. Turning off a few effects will stop the
> glitches, but I all I can do to prevent them is to be conservative about
> how many effects I turn on.
> Just uploaded a little demo to Soundcloud of a recording I made with a
> somewhat similar FX setup to what I mentioned. It was recorded with my
> cell-phone, so it's a bit awful sound quality-wise (also really really
> quiet, whoops...).
> https://soundcloud.com/ovaltine-vortex/raspberry-improv
> If you're curious about the patches and stuff, it's all here, but it's
> hard-coded to MIDI values on the QuNeo and might be a bit confusing:
> https://github.com/YottaSecond/thesisRepo
> On Sun, Apr 6, 2014 at 2:37 PM, Carlos Sanchez <csanchez126 at gmail.com>wrote:
>> Hey list,
>> Thanks for your prompt replies and helpfulness!
>> I could not get qjackctl to work, the audio will not go through and the
>> PD CPU load gets abnormally high at around 67%...
>> I had already played with the sample rate and I had noticed that
>> augmenting the frequency yields better results but the noise was still very
>> present.
>> The sound card itself works correctly with Audacity so I am sure it would
>> work with the arecord and aplay commands Brian suggested. Weirdly, it is
>> only with PD that it is struggling...
>> On a more encouraging note, as Brian suggested, it seems that the problem
>> (or one possibility) is the duplex audio. I haven't thought about using the
>> card as an output only device before and it did work! But afterwards, I was
>> not able to change the settings back and use the noisy duplex audio any
>> more, I was only able to switch the output devices...
>> @Brian: What type of software are you using for the signal processing
>> with the Raspberry Pi? I am very curious because I had first attempted to
>> build this project on a BeagleBone Black but the heavy PD patches made it
>> unstable or crash...
>> On Sat, Apr 5, 2014 at 12:16 PM, Brian Fay <ovaltinevortex at gmail.com>wrote:
>>> If you haven't tried it already, try increasing the latency in the audio
>>> settings (probably not the issue, but worth a shot).
>>> Maybe it's only having trouble with duplex audio (simultaneous input and
>>> output). Do you have both input and output enabled for your soundcard? Does
>>> it work if you only have the output device set, and leave the input device
>>> blank?
>>> You can test to see if duplex audio is working outside of pd - try
>>> running "arecord | aplay" (the vertical bar means pipe the data from
>>> arecord into aplay), and see if you get usable sound. You may need to set
>>> some command line flags on those to get the sample rate and audio devices
>>> right, sorry I don't know them offhand.
>>> I am running a fairly similar setup - for an honors project at my
>>> university, I'm using a Raspberry Pi and Behringer UCG102. I have a nice
>>> multi-effects pedal working at less than 20ms latency. If my Raspberry Pi
>>> can handle it, I feel like your UDOO quad should definitely be able to. I'd
>>> like to add that you have a nice taste in projects :)
>>> On Fri, Apr 4, 2014 at 10:41 AM, Carlos Sanchez <csanchez126 at gmail.com>wrote:
>>>> Yes, I have tried changing sample rates and it has not solved the issue.
>>>> The sound card I am using is basically a copy of the Behringer UCG102
>>>> guitar to USB interface :
>>>> http://www.behringer.com/EN/Products/UCG102.aspx
>>>> On Fri, Apr 4, 2014 at 8:40 AM, tim vets <timvets at gmail.com> wrote:
>>>>> and what is this 'Generic Guitar to USB' exactly?
>>>>> 2014-04-04 3:09 GMT+02:00 Carlos Sanchez <csanchez126 at gmail.com>:
>>>>>> Hello PD-list,
>>>>>> I am currently working on my semester project which is a guitar
>>>>>> multi-effect pedal using the UDOO Quad and PD. I got everything up and
>>>>>> running on the Linaro Ubutu 12.04 LTS build provided by UDOO and I am
>>>>>> having strange results with PD. The soundcard I am using works normally
>>>>>> when I am using Audacity. It plays wav files and can record the guitar
>>>>>> signal correctly but when it comes to PD, a basic osc object or a table
>>>>>> read through ALSA produces a strange digital noise, completely ruining the
>>>>>> audio signal.
>>>>>> I have also tested this setup with a M-Audio Fast Track Pro USB card
>>>>>> and the playback worked without issues, although I could not get the input
>>>>>> signal through the adc object for an unknown reason.
>>>>>> Has anyone tried a similar setup for guitar usage?
>>>>>> Thanks!
>>>>>> _______________________________________________
>>>>>> Pd-list at iem.at mailing list
>>>>>> UNSUBSCRIBE and account-management ->
>>>>>> http://lists.puredata.info/listinfo/pd-list
>>>> _______________________________________________
>>>> Pd-list at iem.at mailing list
>>>> UNSUBSCRIBE and account-management ->
>>>> http://lists.puredata.info/listinfo/pd-list
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20140410/5c9063f3/attachment-0001.htm>

More information about the Pd-list mailing list