[PD] gridflow pd-extended ubuntu 14.04

ub at xdv.org ub at xdv.org
Fri May 2 18:32:58 CEST 2014

On 02.05.2014 16:21, Colet Patrice wrote:
> Le 02/05/2014 15:19, ub at xdv.org a écrit :
>> hello,
>> i have dedicated some time to updating my system, ending up with ubuntu
>> 14.04 doing the occasional patching now.
>> everything pd related went relatively painless, just had to rebuild Gem,
>> but gridflow's stuck and won't move a bit and i have no clue.
>> i have gridflow in it's own builddir: /home/ub/build/gridflow
>> here i do update per svn, then configure and make, but when loading in
>> pd i consistently get:
>> home/ub/build/gridflow/gridflow.pd_linux:
>> /home/ub/build/gridflow/gridflow.pd_linux: undefined symbol: cvEllipse
>> gridflow: can't load library
>> /home/ub/build/gridflow/gridflow_gem9393.pd_linux:
>> /home/ub/build/gridflow/gridflow_gem9393.pd_linux: undefined symbol:
>> _ZTI7FObject
>> gridflow_gem9393: can't load library
>> system is amd64, pd: 0.43-3, GEM: 0.93.3, gridflow says it's "At
>> revision 6881"
>> ideas anyone?
>> thanks+ciao,
>> ub
>> _______________________________________________
>> Pd-list at iem.at mailing list
>> UNSUBSCRIBE and account-management ->
>> http://lists.puredata.info/listinfo/pd-list
> hello,
>  it seems that gem libraries aren't linked correctly by the build
> system, gridflow might run if Gem libs are disabled in configure,
> what about posting build logs?
> patko

thanks for the quick reply.

i tried ./configure --no-opengl
upon make distclean but that lead to the same result for
gridflow.pd_linux: undefined symbol: cvEllipse

as this seems an openCv object, which is included directly by
gridflow (not via Gem) from src/opencv.cxx
i checked the config.log for opencv and really there was a line saying:
"Package opencv was not found in the pkg-config search path"

installing libopencv-dev fixed that and it's all good now :)


More information about the Pd-list mailing list