[PD] sox > fifo > readsf~ not working

Ali Momeni via Pd-list pd-list at lists.iem.at
Thu Jun 19 13:47:30 CEST 2014

hello all,
i'm trying to catch some internet radio streams with sox and pass the audio
to pd to process it.

so i first make a fifo buffer:

*mkfifo ~/tempaudio*

then i run a sox command that catches an mp3 stream, and writes it to a
wave stream in the fifo buffer made above:

*sox -v .9 -t mp3 http://icy-e-04.sharp-stream.com:80/lincsfmrutland.mp3
<http://icy-e-04.sharp-stream.com/lincsfmrutland.mp3> -t wav -input-buffer
80000 -r 22050 -c 1 ~/tempaudio*

these commands run with no errors; i'm executing both as "sudo".

then i open pd and try to run readsf~ with the fifo file above as the input.
when i send the "open" message to readsf~, i have no error:

* open ~/tempaudio*

then i send the "start" message message and i get an error:

*dsp:/home/pi/tempaudio: unknown or bad header format*

i've tried some other params in the sox write command but i get the bad
header error no matter what i do.

any thoughts?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20140619/7d1262f6/attachment.html>

More information about the Pd-list mailing list