[PD] Compile error on Odroid-U3

IOhannes m zmoelnig zmoelnig at iem.at
Tue Sep 2 13:41:01 CEST 2014

Hash: SHA256

On 2014-09-02 10:44, Alexandros Drymonitis wrote:
> On Sun, Aug 31, 2014 at 8:56 PM, Roman Haefeli <reduzent at gmail.com>
> wrote:
>> On Sam, 2014-08-30 at 19:02 +0300, Alexandros Drymonitis wrote:
>>> On Sat, Aug 30, 2014 at 5:31 PM, IOhannes m zmölnig
>>> <zmoelnig at iem.at> wrote: On 08/30/2014 10:57 AM, Alexandros
>>> Drymonitis wrote:
>>>> /dev/mmcblk0p2  3.3G  3.1G  2.0M 100% /
>>> well, this means that you filesystem *is* full. I managed to
>>> install Pd with apt-get. Any idea why there's no space to 
>>> compile from source but can install from the repos?

well, the puredata package will be considerably smaller than the
build-process (which also contains a large number of intermediate
binary files; and the resulting binary is not (yet) stripped of
uneeded symbols.
e.g. if i install Pd on my debian system using the "puredata" package
it will take about 5.7MB, whereas if i build it myself the pd
directory contains about 34MB of data (after the build; not counting
the 20MB in the .git directory which i expect not to be there when
using the tarball)

>> A possible scenario would be that there was enough space to
>> install Pd from the repository, but later there was not enough
>> space left for compiling Pd. Either way, it's moot to further
>> investigate the reason, since the reason is clear: Your
>> filesystem is full, as IOhannes clearly stated before. The only
>> way to deal with that is to free some space deleting files or
>> moving them to another partition or storage device.
> I've only installed libtool, automake and jack before I tried to
> compile Pd. Everything else that's in the filesystem came with the
> image installed in the eMMC module. Any suggestions as to what I
> should delete?

anything you don't need...
(it's hard to answer this without being too snarky).
since you only installed so few things, it seems that you are using a
pre-made system image.
probably the image comes with a number of fancy software installed,
including a full fledged desktop environment (like gnome), an office
suite (like libreoffice) and what not.

check what you have, think what you will never use and throw it away.

in the meantime, you might want to start thinking about why you have
an 8GB disk and you only see 3.5GB (on two partitions).

- - maybe you are not using the emmc module at all
- - maybe there is a large unused/unpartioned space on the emmc module.
- - maybe you bought an 8GB module but only got a 4GB one.

in any case, check
$ cat /proc/partitions

> I started a new thread about a new error message I get when I tried
> to run Pd, which is:

i'll come to that in the other thread then.

Version: GnuPG v1


More information about the Pd-list mailing list