[PD] (Solved) pd~ subprocess not responsive

Max abonnements at revolwear.com
Mon Sep 8 05:44:19 CEST 2014

Hash: SHA1

do you use jack1 or jack2? I have to use the later.

Anyways, I solved it. Didn't have the development files installed.
after adding libjack-jackd2-dev it compiled. Was getting this before:

make -f makefile.gnu JACK=TRUE
- -DINSTALL_PREFIX=\"/usr/local\" -Wall -W -Wstrict-prototypes
- -Wno-unused -Wno-unused-parameter -Wno-parentheses -Wno-switch
- -funroll-loops -fomit-frame-pointer    -c -o ../obj/s_audio_jack.o
s_audio_jack.c:15:27: fatal error: jack/weakjack.h: No such file or
 #include <jack/weakjack.h>
compilation terminated.
make: *** [s_audio_jack.o] Error 1

On 09/08/2014 12:30 PM, Miller Puckette wrote:
> Odd - I just now tried recompiling Pd 0.46 with jack and it
> compiled and ran fine (on Fedora 20)... just did "make -f
> makefile.gnu JACK=TRUE" in pd/src and no problems.  I'm curious
> what went wrong for you.
> cheers M
> On Mon, Sep 08, 2014 at 12:17:25PM +0900, Max wrote: Both are
> vanilla. What I am using is the Debian package Pd 0.45.4 and what I
> compiled and installed was Pd 0.46.0. I can't use the newer one
> because I wasn't able to get it to compile with jack... but that's
> another issue. I am fine with  Pd 0.45.4 for the moment. I am not
> 100% sure what was going on, but the paths were "polluted" after
> the install so the repository version looked for pd~ in the wrong
> place. The pd~ which was found there did not work, may be because
> it was compiled without jack?
> m.
> On 09/08/2014 04:06 AM, Miller Puckette wrote:
>>>> This is strange - Pd extended should be using a different
>>>> spot (~/.pdextended on linux) than pd vanilla to store user
>>>> preferences. So I don't know why the two should be stepping
>>>> on each others' toes like this.
>>>> chers Miller
>>>> On Sat, Sep 06, 2014 at 11:20:55PM +0900, Max wrote: (I think
>>>> the Gem error is unrelated, so I'm better opening another
>>>> thread)
>>>> with the pd~-help i am experiencing the problem, that I can't
>>>> move the objects in edit mode, clicked message boxes will
>>>> keep their highlighted border permanently. That's only in the
>>>> child process. Audio and Messages however can be sent from
>>>> and to the subprocess.
>>>> --- SOLUTION
>>>> before sending the mail I found the problem, It may be useful
>>>> as a future reference, so I am sending it anyways:
>>>> I suspect that when trying to install the current Pd, I
>>>> re-set the path settings.
>>>> So in verbose mode I noticed that pd~ was found in 
>>>> /usr/local/lib/pd/extra I removed that path from the path
>>>> settings and now pd~ is found somewhere else. It is the same
>>>> (v0.3) but it works now.
>>>> tried /usr/lib/puredata/tcl/../extra/pd~/pd~.pd_linux and 
>>>> succeeded
>>>>> _______________________________________________ 
>>>>> Pd-list at lists.iem.at mailing list UNSUBSCRIBE and 
>>>>> account-management -> 
>>>>> http://lists.puredata.info/listinfo/pd-list

Version: GnuPG v1


More information about the Pd-list mailing list