[PD] libdir path
IOhannes m zmölnig
zmoelnig at iem.at
Wed Nov 12 19:49:29 CET 2014
On 11/10/2014 12:55 AM, Jonathan Wilkes via Pd-list wrote:
> On 11/08/2014 01:05 AM, IOhannes zmölnig wrote:
>> Could you share some use-cases?
> My own starting point was a regression test patch for loading all
> potentially loadable binaries which come with a particular pd
> installation package. (Well, I say regression test-- when I ran it for
> the first time it revealed a few objects which have probably always
> crashed Pd-extended.)
> Since the directory that houses "extra" also houses "doc", I just went
> ahead and made a method for "libdir", which looked to point to parent
> directory of those two directories.
so the main purpose of the "libdir path" is indeed to find the "extra"
path - i don't think the "doc" path is super-interesting, as these days
libraries don't install to it (any more), so content under "doc/" is
but if "extra" is what you after, then i thik the valueS of
"sys_staticpath" are more intersting, as these enumerate all default
search paths ("all extra paths").
>>> but maybe there's a better name for that method since it
>>> conflicts with the name for anl self-contained external library that
>>> adheres to Hans' standard format.
>> How about "pdinstalldir"? (prefixed 'pd' to avoid confusion with the
>> "install" path of the patch.)
> I don't understand what this means. What would the "install" path of a
> patch be?
well, just the path of the patch, but viewed from an application pov,
where you ship an application written in Pd (as opposed to the
i'm aware that you have already added other ways to query *this* info.
> I have the scope of the query in the name of the object: [pdinfo].
> Currently I have [dir(---[pdinfo] pointing to the directory of the pd
> executable, but I guess that could be changed.
so this returns `/usr/(local/)?bin` on an ordinary linux installation?
> Anway, what you are calling "pdinstalldir" would return the single
> directory I am currently calling "libdir". Is that correct?
yes. this was just a suggestion for an alternate name of "libdir" which
does not require the user to know anything about filesystem hierarchy
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 819 bytes
Desc: OpenPGP digital signature
More information about the Pd-list