[PD] [PD-announce] pd 0.46-4, fixes crasher bug in 0.46-3

IOhannes m zmölnig zmoelnig at iem.at
Thu Jan 22 22:54:19 CET 2015

On 01/22/2015 10:26 PM, Roman Haefeli wrote:
> On Son, 2014-12-21 at 08:50 -0800, Miller Puckette wrote:
>> I just tried this in 0.46-4:
>> cd .../pd/src
>> make -f makefile.gnu JACK=TRUE
>> ../bin/pd -jack
>> and it seems to work fine for me.  So there could be a jack version
>> conflict, or just possibly something amiss in the configure script.
> I guess you're on spot with your last guess (I tried the most recent
> release to see whether it might make my jack problem disappear, but it
> doesn't).
> I know now that the problem is not a general one, but specific to my
> box. I can run 'pd -jack' on other computers without problems. On the
> non-working computer, the resulting pd binary is not linked against any
> libjack* library:
> $ ldd /usr/local/bin/pd
> 	linux-gate.so.1 =>  (0xb7753000)
> 	libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xb76e3000)
> 	libasound.so.2 => /usr/lib/i386-linux-gnu/libasound.so.2 (0xb75ed000)
> 	libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xb75d0000)
> 	libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xb75cb000)
> 	libfftw3f.so.3 => /usr/lib/i386-linux-gnu/libfftw3f.so.3 (0xb73dc000)
> 	libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xb722d000)
> 	/lib/ld-linux.so.2 (0xb7754000)
> 	librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xb7224000)

hmm weird, it seems to work for me with Pd-0.46-5, compiled with
autotools and the flags you were giving.
i also have the same jack version (but am running Debian/sid on amd64)

i think the problem you are facing is that libjack is not linked in, and
thus the symbols do not resolve properly (weak linking seems to be
enabled, so the entry points to the jack functions are set to 0x0; the
first time you call one of them, you get a segfault).

i also don't understand why your binary is linked against libfftw3f, if
you don't enable fftw manually (--enable-fftw)

> My understanding of the build system is too limited to know where cause
> of this problem might be. Maybe I try a fresh 'git clone' next.

yes, please try with 0.46-5.
also make sure to run "make distclean" before (if you are just upgrading
an older checkout), and eventually run "./autogen.sh" before configure...


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20150122/cd0d3c31/attachment.sig>

More information about the Pd-list mailing list