[PD] VLC 2.1.x and Gem

Olivier Baudu olivier at labomedia.net
Wed Mar 4 20:48:15 CET 2015


You can use ffmpeg + v4l2loopback to make a "virual" video device 
openable with gem...

Here's an example of the command line :
ffmpeg -i rtsp:// -pix_fmt yuv420p -an -r 25 -f 
v4l2 /dev/video69

(http and rtmp work too)

But ffmpeg must be built with the v4l2loopback backend.
The static one here works : http://ffmpeg.gusari.org/static (unreachable 
right now... :-/ )

Here's some documentations, but it's in french, sorry :



"On ne peut pas vivre dans un monde où l'on croit que l'élégance exquise 
du plumage de la pintade est inutile. Ceci est tout à fait à part. J'ai 
eu envie de le dire, je l'ai dit." Jean Giono, Un roi sans 

Le 04.03.2015 20:29, Etienne Landon a écrit :
> Hi list,
> I want to get web camera streams into Gem, with different streaming
> formats (mainly http and rtmp). VLC plugin seems like the perfect way
> to handle that, but I can't get it to work with Gem.
> I know pdgst could be a solution but vlc has the advantage that I
> could handle any stream type the same way (where gst needs a different
> pipe).
> On Mint17 and Ubuntu 14.04 Gem crashes with segfault as soon as I try
> to open anything with VLC (like |driver vlc, screen://(  )
> Both use vlc 2.1.4, I also tried 2.1.6 (vlc stable-daily ppa), same
> behaviour.
> Having seen this thread [1], I tried the symlink removal without
> success, so made a gdb backtrace (attached with this message, usefull
> information are in the last lines)
> Config for this backtrace is :
> Freshly installed, updated Ubuntu 14.04.1
> VLC 2.1.4
> pd-extended 0.43.4
> Gem 0.93.git 374f713 freshly compiled
> I had success regarding VLC and Gem on Ubuntu 13.10, which uses vlc
> 2.0.8. But with that vlc version, my stream is really long to start
> and stops after one minute or so. VLC behaviour between 2.0.8 and
> 2.1.4 regarding rtmp looks very different, in vlc 2.1.x changelog they
> say "New RTMP input module, using libavformat!", which might explain
> that (seems that it was ffmpeg before).
> Has anyone successfully compiled vlc plugin for gem with recent vlc
> version ? Or any idea what other solution I could try ?
> Links:
> ------
> [1] http://sourceforge.net/p/pd-gem/bugs/211/
> _______________________________________________
> Pd-list at lists.iem.at mailing list
> UNSUBSCRIBE and account-management ->
> http://lists.puredata.info/listinfo/pd-list

More information about the Pd-list mailing list