[PD] MIDI connection problem with commandline-parameters

cornicis cornicis at googlemail.com
Fri Oct 9 17:41:34 CEST 2015

I picked Qjackctl and defined a standard patchbay, though there's a need
for an xserver now. I will switch to udev if there's a need for better

I'm still wondering why autoconnecting worked before if a MIDI device
was already connected, but I leave it at that for the time being. Thanks
for your replies!


On 08.10.2015 18:57, Dan Wilcox wrote:
> You’re probably doing it too quickly after launching pd. I usually
> sleep a second or two after starting pd before calling aconnect in my
> scripting. Pd probably sets up the midi connection to ALSA much more
> quickly on your desktop than on the pi which is why it works on 1 and
> not on the other.
> Also, I recommend looking up writing custom udev rules to
> automatically call aconnect whenenever you hotplug the midi device. I
> use this and it it’s great since I don’t have to worry if anything is
> unplugged, etc.
> --------
> Dan Wilcox
> @danomatika <https://twitter.com/danomatika>
> danomatika.com <http://danomatika.com>
> robotcowboy.com <http://robotcowboy.com>
>> On Oct 8, 2015, at 7:41 AM, pd-list-request at lists.iem.at
>> <mailto:pd-list-request at lists.iem.at> wrote:
>> *From: *cornicis <cornicis at googlemail.com
>> <mailto:cornicis at googlemail.com>>
>> *Date: *October 8, 2015 at 7:09:22 AM MDT
>> *To: *pd-list at lists.iem.at <mailto:pd-list at lists.iem.at>
>> *Subject: **Re: [PD] MIDI connection problem with commandline-parameters*
>> Thanks for the fast response!
>> On 08.10.2015 13:55, IOhannes m zmoelnig wrote:
>>> On 2015-10-08 13:39, cornicis via Pd-list wrote:
>>>> won't get any MIDI input 
>>>> (miditest.pd is just printing incoming midi notes).
>>> isn't this what you want? if you don't get MIDI input, how can it print
>>> incoming midi notes?
>> I guess there's some misunterstanding, I don't think that miditest.pd or
>> generally PD-MIDI is faulty, you're completely right: as long as nothing
>> is connected, nothing can get printed.
>> My problem lies in having my MIDI-controller connected on PD-startup.
>> Right now my only possibility to connect without GUI is to execute
>> "aconnect 20, 128" after PD has opened MIDI. To speak more concretely:
>> after starting PD with mididev-parameters I want to have Arduino
>> connected to PureData in aconnect -l. This works on my desktop machine
>> but not on the fresh updated raspberry.
>>>> $ puredata -d 3 -verbose -nogui -alsamidi -midiindev 1  -listdev
>>> try "-mididev 2" (or "-midiindev 2" if you prefer)
>> I retried, but I already tested various configurations. For now I tried:
>> -mididev and -midiindev with parameters 0/1/2/3/20/21
>> -midiaddindev 'Arduino Leonardo' and 'Arduino Leonardo MIDI 1' which
>> unfortunately didn't open any ALSA Client.
>> As expected compiling 0.46.7 didn't help. Root privileges didn't help
>> either.
>> I'm pretty clueless what my next steps would be to trace this issue. As
>> MIDI works in ALSA and PD I think there has to be a communication
>> problem on opening the ALSA client. Maybe I'm missing a package? What's
>> involved in setting the MIDI connection on startup? I supposed that PD
>> uses aconnect itself to connect to MIDI devices, but maybe there's
>> something different going on?
>> Cheers,
>> Daniel

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20151009/c4eeb733/attachment-0001.html>

More information about the Pd-list mailing list