[PD] Pd can't find its help files

Claude Heiland-Allen claude at mathr.co.uk
Tue Feb 9 22:25:25 CET 2016

On 09/02/16 20:55, Andrea wrote:
> Pd-0.43.0 on Linux/x86_64 can't seem to find its help files.

How did you install it?  (Works fine for me on Debian Wheezy, both from 
packages and compiled from source, so I think this is more likely to be 
a packaging problem rather than a Pd bug.)

> I have the
> path in ~/.pdsettings :
> 	path1: /opt/pkg/share/doc/pd/doc
> while Pd is installed in /opt/pkg/bin/ . Here's what I see in Pd's
> console when trying to get help - for example - on a "float":


> So, Pd isn't even looking in /opt/pkg/share/... - path1 notwithstanding.

Pd has a separate help path.

> What else does Pd need to be able to find its own help files?

 From the command line (or ~/.pdrc) you can use -helppath instead of 
-path, not sure what the syntax is for ~/.pdsettings (sorry).

$ pd -helppath /opt/ -verbose -stderr
tried ./osc~-help.pd and failed
tried /opt/osc~-help.pd and failed
tried /home/claude/opt/lib/pd/doc/5.reference/osc~-help.pd and succeeded

(2nd line shows it looking in the argument directory, 3rd line is from 
'make install' into my preferred prefix)

You could maybe create a symlink to the correct location, as the 
puredata(-doc) Debian package seems to do.


More information about the Pd-list mailing list