[PD] Messed font files

Alexandros Drymonitis adrcki at gmail.com
Wed Feb 24 11:14:36 CET 2016

This problem doesn't concern Pd only, but it started through Pd (well, I
started it) and it is related to Pd, so I'm posting it here.
I've recently dual booted my laptop with Debian Jessie XFCE and in general
all is working fine. While doing some stuff in Pd (that's 0.46.2 from the
Jessie repositories) I created a [text2d] and got this error message:
[text2d]: cannot find font-file

So I looked in /usr/share/fonts/truetype and saw there was a dejavu/
directory, which had some font files in it, including DejavuSans.ttf. Now,
not being very linux-savvy, I changed the name of the directory to
ttf-dejavu/. [text2d] worked fine, but ever since, when I open Pd, I get
this message:
WARNING: Font family 'DejaVu Sans Mono' not found, using default (Courier
10 Pitch)

I tried to rename the directory back to dejavu/, but now the corresponding
font file is a "broken symbolic link to ../dejavu/DejaVuSansMono.ttf"

Renaming the directory back to ttf-dejavu/ doesn't work for [text2d] either.
It's a bit annoying because Pd's font is now quite small, and even if I
include the -font-size-12 flag in the Startup flags, if I open an existing
patch, the font goes back to 10, and the letters are quite small. I now
realize that this wasn't a very smart thing to do, but I did it...
All this might make sense to people who know the Linux system well, but
that's not the case with me and I'm experimenting. So, anyone knows a
solution to this? It would be nice if I could solve both  problems, Pd not
finding DejavuSansMono.ttf and [text2d] not finding DejavuSans.ttf

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20160224/b4b852d1/attachment.html>

More information about the Pd-list mailing list