[PD] Messed font files

Dan Wilcox danomatika at gmail.com
Wed Feb 24 17:11:19 CET 2016

Sounds like the font files themselves in that folder were system links <https://en.wikipedia.org/wiki/Symbolic_link>  so the fonts actually live elsewhere. In general, you do *not* want to change the folder structure outside of your /usr/home/USERNAME folder since the package management & OS rely on it.

I’d start by fining which package installs the font and creates the symlinks and then force install it. For Debian-based distros, I often use the Ubuntu package search to see which package contains the files I’m looking for. In this case, it looks like “font-dejavu-core”: http://packages.ubuntu.com/wily/all/fonts-dejavu-core/filelist <http://packages.ubuntu.com/wily/all/fonts-dejavu-core/filelist>

If the font is back, then the issues related to GEM looking in the wrong path could be fixed via IOHannes or some GEM dev updating/making a new font search path to GEM. In the meantime, you can do a quick and dirty fix by making a symlink from the new font dir to the one GEM is looking for:

sudo ln -s  /usr/share/fonts/truetype/dejavu/ /usr/share/fonts/truetype/ttf-dejavu/

This way you will have both folders & one of them is just a link to the other.

Dan Wilcox
@danomatika <https://twitter.com/danomatika>
danomatika.com <http://danomatika.com/>
robotcowboy.com <http://robotcowboy.com/>
> On Feb 24, 2016, at 4:00 AM, pd-list-request at lists.iem.at wrote:
> From: Alexandros Drymonitis <adrcki at gmail.com <mailto:adrcki at gmail.com>>
> Subject: [PD] Messed font files
> Date: February 24, 2016 at 3:14:36 AM MST
> To: "pd-list at lists.iem.at <mailto:pd-list at lists.iem.at>" <pd-list at lists.iem.at <mailto:pd-list at lists.iem.at>>
> This problem doesn't concern Pd only, but it started through Pd (well, I started it) and it is related to Pd, so I'm posting it here.
> I've recently dual booted my laptop with Debian Jessie XFCE and in general all is working fine. While doing some stuff in Pd (that's 0.46.2 from the Jessie repositories) I created a [text2d] and got this error message:
> [text2d]: cannot find font-file '/usr/share/fonts/truetype/ttf-dejavu/DejaVuSans.ttf'
> So I looked in /usr/share/fonts/truetype and saw there was a dejavu/ directory, which had some font files in it, including DejavuSans.ttf. Now, not being very linux-savvy, I changed the name of the directory to ttf-dejavu/. [text2d] worked fine, but ever since, when I open Pd, I get this message:
> WARNING: Font family 'DejaVu Sans Mono' not found, using default (Courier 10 Pitch)
> I tried to rename the directory back to dejavu/, but now the corresponding font file is a "broken symbolic link to ../dejavu/DejaVuSansMono.ttf"
> Renaming the directory back to ttf-dejavu/ doesn't work for [text2d] either.
> It's a bit annoying because Pd's font is now quite small, and even if I include the -font-size-12 flag in the Startup flags, if I open an existing patch, the font goes back to 10, and the letters are quite small. I now realize that this wasn't a very smart thing to do, but I did it...
> All this might make sense to people who know the Linux system well, but that's not the case with me and I'm experimenting. So, anyone knows a solution to this? It would be nice if I could solve both  problems, Pd not finding DejavuSansMono.ttf and [text2d] not finding DejavuSans.ttf
> Thanks

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20160224/887d181d/attachment.html>

More information about the Pd-list mailing list