[PD] linux: "-font-size" startup flag -- does this work?

Alexander Connor a.connexx at runbox.com
Mon Sep 11 19:02:44 CEST 2017

Hello list -

So whilst testing some of the newer Debian/Ubuntu versions to replace my EOL/close to EOL versions I'm currently using, I ran into the enlarged font rendering issue in Vanilla which has been discussed in various posts to this list and I am aware the devs are still working on this.

I attempted some temporary workarounds. I first tried the GUI Edit->Font option. In pre 0.48 Vanilla, this would change the object box font size (this seems not to be the case in 0.48 as it is now applied to to the window menu fonts???) but this didn't cut it as I needed size that was in between the GUI selectable values.

So I then turned to the -font-size startup flag, and found that no matter what value I put in, on any of the last few revisions of 0.47 or even 0.48, this flag seemed to do *absolutely nothing*. Tried with and without quotes around the variable -- nada. I tested -font-face and -font-weight and these worked as expected. Am I missing something here? Should I file a bug?

BTW I tried searching for -font-size in the archive, but this buries you with the "font-size" line in all the headers in those "attachment" files. Couldn't find any way to filter those. Not very useful.

More information about the Pd-list mailing list