[PD] Fwd: Re: linux: "-font-size" startup flag -- does this work?

Alexander Connor a.connexx at runbox.com
Tue Sep 12 03:52:39 CEST 2017

----- Start Forwarded Message -----
Sent: Mon, 11 Sep 2017 21:49:42 -0400 (EDT)
From: "Alexander Connor" <a.connexx at runbox.com>
To: "Lucas Cordiviola" <lucarda27 at hotmail.com>
Subject: Re: [PD] linux: "-font-size" startup flag -- does this work?

Ah yes thank you I forgot that and was using the wrong GUI window menu --

Unfortunately though, it still doesn't help with this problem because what I need is a size 9, and as I mentioned this is an "in between" variable that isn't available in the GUI options.

Is there a control channel that I could send the desired font size through within the patch to bypass the limited GUI switching?  Or alternatively (but much less desirability) a variable to edit within the text file (is that what the last number is in the canvas parameters at the beginning of the file)?  

Those things aside, there's still one thing I don't understand about the -font-size flag.  As I mentioned -font-face and -font-weight produce the effect I expected -- that is, they change the face and weight of all patches opened after Pd starts up -- but not -font-size.  If what you say is the case (sorry haven't been able to test it yet) isn't this a bit inconsistent with the functioning of the other font control flags?

On Mon, 11 Sep 2017 18:00:34 +0000, Lucas Cordiviola <lucarda27 at hotmail.com> wrote:

> hi,
> The "-font-size" flag will affect your *new* patches. Saved patches have 
> their font size saved.
> If you want to change the font of a saved patch use the "GUI Edit->Font 
> option" of that particular window, not the Pd window (the one with the 
> console).
> Hope this helps.
> Mensaje telepatico asistido por maquinas.
> On 9/11/2017 2:02 PM, Alexander Connor wrote:
> > Hello list -
> >
> > So whilst testing some of the newer Debian/Ubuntu versions to replace my EOL/close to EOL versions I'm currently using, I ran into the enlarged font rendering issue in Vanilla which has been discussed in various posts to this list and I am aware the devs are still working on this.
> >
> > I attempted some temporary workarounds. I first tried the GUI Edit->Font option. In pre 0.48 Vanilla, this would change the object box font size (this seems not to be the case in 0.48 as it is now applied to to the window menu fonts???) but this didn't cut it as I needed size that was in between the GUI selectable values.
> >
> > So I then turned to the -font-size startup flag, and found that no matter what value I put in, on any of the last few revisions of 0.47 or even 0.48, this flag seemed to do *absolutely nothing*. Tried with and without quotes around the variable -- nada. I tested -font-face and -font-weight and these worked as expected. Am I missing something here? Should I file a bug?
> >
> > BTW I tried searching for -font-size in the archive, but this buries you with the "font-size" line in all the headers in those "attachment" files. Couldn't find any way to filter those. Not very useful.
> >
> > _______________________________________________
> > Pd-list at lists.iem.at mailing list
> > UNSUBSCRIBE and account-management -> https://lists.puredata.info/listinfo/pd-list

----- End Forwarded Message -----

More information about the Pd-list mailing list