[PD] Trouble Re-Installing Gem

Greg Zifcak greg at gzifcak.net
Thu Oct 12 17:10:01 CEST 2017

Thanks for the input all. I saw the mailing list archive but my search skills must be lacking.

To clarify, I originally downloaded the Gem folder and placed it in the folder next to the Pd application file, and assumed correctly that this would not do anything. That is when I found out about the help menu installation feature, and installed it from there.

My installation process in attempting to fix the problem was: delete existing Pd folders, download Pd 0.48 or 0.47 32 bit from https://puredata.info/downloads/pure-data, then install Gem from the help menu.

I finally solved the issue by adding the path to the Gem folder (Contents/Resources/extra) to "Startup" in "Preferences". What led me down this course of investigation was that I noticed that the path Pd said it was installing Gem was Contents/Resources/Scripts/extra, even though it wasn't really putting it there. I don't know why it didn't add a path to startup; I'm guess it did on the first install when it originally worked. I also still don't understand how the installation knew to warn me that a previous folder didn't exist, since I deleted the folder structure and couldn't find any other Pd folders on my system. 

After some of the failed installation attempts before I added the path, gemwin and gemhead appeared to be created correctly, but pix_draw and pix_texture did not (dotted lines). I assume that Gem wasn't being loaded at all since I hadn't added the path yet, and that the graphics were just inconsistent.

Anyway, glad it's working again and I've learned a little more about how installation is supposed to work.

> On Oct 12, 2017, at 3:59 AM, IOhannes m zmoelnig <zmoelnig at iem.at> wrote:
> On 2017-10-11 18:39, Greg Zifcak wrote:
>> New to the list and new to Pd, aside from various quick experiments over the years. 
>> A few days ago I installed the 32 bit version of Pd 0.47-1 on my Macbook Pro running 10.11.6. I downloaded Gem 0.93.3 and put it in the same folder as my Pd app. I then learned that I could download and install it from the help menu, which I did, and it worked.
> so you installed, and it probably worked.
> and then you installed it again, and it worked?
> why did you install it two times?
>> After this I tried deleting and re-installing Pd and Gem several
>> times,
> how?
>> Next time I opened it, it gave me "couldn't create" messages for 
>> some Gem objects but not all. 
> [...]
>> using both 0.48 and 0.47 versions, with the result being that all or some of the Gem objects won't work.
> it might help to be a bit more or less specific.
> gfdmasdr
> IOhannes
> _______________________________________________
> Pd-list at lists.iem.at mailing list
> UNSUBSCRIBE and account-management -> https://lists.puredata.info/listinfo/pd-list

More information about the Pd-list mailing list