[PD] Pd on Tiny Core Linux on Raspberry Pi

Dan Wilcox danomatika at gmail.com
Wed Feb 7 09:50:26 CET 2018

Looks like an issue with autoconf of your system. If we used a dist tarball with pregenerated configure scripts, this probably wouldn't be an issue since then autoconf and automaker are not needed, just gcc and make.

If you have any more time, you could try building a dist tarball on your main system and then build Pd with it using configure/make on the pi. Building the tarball is:

make dist

That gives you a pd-0.48.1.tgz with the pregenerated configure scripts.

enohp ym morf tnes
Dan Wilcox

> On Feb 7, 2018, at 8:30 AM, Chris McCormick <chris at mccormick.cx> wrote:
> Hi Dan,
> On 03/02/18 21:15, Dan Wilcox wrote:
> > Out of curiosity, does the autotools build work as well?
> I got this when I tried:
> tc at box:~/pure-data$ autoconf
> configure.ac:9: error: possibly undefined macro: AM_INIT_AUTOMAKE
>      If this token and others are legitimate, please use m4_pattern_allow.
>      See the Autoconf documentation.
> configure.ac:149: error: possibly undefined macro: AM_CONDITIONAL
> configure.ac:162: error: possibly undefined macro: AC_LIBTOOL_DLOPEN
> configure.ac:163: error: possibly undefined macro: AC_LIBTOOL_WIN32_DLL
> configure.ac:164: error: possibly undefined macro: AC_PROG_LIBTOOL
> configure.ac:230: error: possibly undefined macro: AC_CHECK_LIBM
> Then when I tried to run configure:
> tc at box:~/pure-data$ ./configure
> configure: error: cannot find install-sh, install.sh, or shtool in m4/config "."/m4/config
> I guess there are some additional build dependencies I'd need to install to get this working.
> For now the old makefile.gnu route works great on this platform.
> Cheers,
> Chris.
> -- 
> http://mccormick.cx/

More information about the Pd-list mailing list