[PD] PdLua on Mac OS X El Capitan not working

Jens Ahrens jens.ahrens at chalmers.se
Mon May 7 15:08:27 CEST 2018

Hi Dan,

Thanks for trying! I’m on Mac OS X 10.11.6.

I’ve played around with the 32 and 64 versions of pd, and the outcome is always the same: (Apart from the very first try) the libraries are downloaded and deken adds the paths to pd correctly. All libraries that I’ve tried work apart from PdLua.

I haven’t managed to start pd in verbose mode. I’ve tried something like this (with variations)

	open -a Pd-0.48-1.app --args -verbose

but I’m getting the error

	LSOpenURLsWithRole() failed for the application /Applications/Pd-0.48-1.app with error -10810.

This seems to suggest an issue with the access rights, but those appear to be ok.

This call

	open -a Pd-0.48-1.app


Am I making a mistake here?


> On 07 May 2018, at 13:01, Dan Wilcox <danomatika at gmail.com> wrote:
> I just installed it and the library is loading for me on 10.13 with 0.48-1. I let Deken add the path for me and was able to create a [pdlua] object directly. Do you have any other settings or paths which might be conflicting? You could run Pd in verbose mode to see how it's looking for pdlua.
> I'm also running the 32 bit Pd, although the external is built for 32 and 64 bit, so it should work on either.
>> On May 7, 2018, at 12:49 AM, pd-list-request at lists.iem.at wrote:
>> Date: Sun, 6 May 2018 13:56:18 +0000
>> From: Jens Ahrens <jens.ahrens at chalmers.se>
>> To: "pd-list at lists.iem.at" <pd-list at lists.iem.at>
>> Subject: [PD] PdLua on Mac OS X El Capitan not working
>> Message-ID: <93103056-4361-4ED1-A7FF-EE676EB37CBA at chalmers.se>
>> Content-Type: text/plain; charset="utf-8"
>> Hello everyone,
>> I used the latest pre-compiled vanilla distribution from https://puredata.info/downloads/pure-data . 
>> I then installed a few externals according to the official instructions using "Help -> Find externals” inside pd. It worked well for iemlib and iemnet.
>> I didn’t get an error message when installing PdLua. The according files were indeed downloaded to my computer. Interestingly, the path to PdLua was not added automatically to the pd path list. It was added for iemlib and iemnet though. 
>> Even if I add the path to PdLua manually, no Lua objects inside my pd patches are being recognised. Even not in the PdLua help files.
>> I’d be grateful for any ideas!
>> Greets,
>> Jens
> --------
> Dan Wilcox
> @danomatika
> danomatika.com
> robotcowboy.com

More information about the Pd-list mailing list