[PD] GEM crash on debian - video codecs in linux

oliver oliver at klingt.org
Tue May 8 16:03:31 CEST 2018

hi, just tried to get a simple video patch to work under linux and got a 
segfault crash when trying to load a video encoded with the "UT" codec.

a more general question before going into details:

what video codecs are people on this list using in a linux environment 
for [pix_film] ? my requirements are:

* should not alter colors (so h264 is out)
* should decompress easily
* should respond immediately to frame messages (for good a/v sync)
* should allow alpha channel

in windows and OSX the "UT" codec was so far my codec of choice, because 
it's very light on the CPU while decoding (huge filesizes though) and is 
"visually lossless". on OSX "prores" was also fine. but both of them 
crash PD (or rather "libgmerlin") in linux. strange because mplayer, 
ffplay, vlc etc. can play them

PD 0.48.0
Gem 0.93.3
Debian stretch 9.1

thanks for any ideas in this regard !


now for my crash report:

i opened [pix_film]'s helpfile and opened a movie file encoded with UT 
(another version had PRORES - same crash) and got an immediate segfault 
and PD quit.

i tried again with loglevel 4 and it showed this (on opening the patch):


open: /etc/pd/gem.conf: No such file or directory
open: /home/oliver/.pd/gem.conf: No such file or directory
open: ./gem.conf: No such file or directory
load plugins 'film' in '/usr/local/lib/pd/extra/Gem/'
pattern : /usr/local/lib/pd/extra/Gem/gem_film*.so
dylib loading file '/usr/local/lib/pd/extra/Gem/gem_filmAVIPLAY.so'!
<init> : Avifile RELEASE-0.7.48-170225-04:54-../src/configure
<init> : Available CPU flags: fpu vme de pse tsc msr pae mce cx8 apic 
sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht 
tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good 
<init> : 2999.90 MHz Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz processor 
dylib loading file '/usr/local/lib/pd/extra/Gem/gem_filmGMERLIN.so'!
dylib loading file '/usr/local/lib/pd/extra/Gem/gem_filmMPEG3.so'!
dylib loading file '/usr/local/lib/pd/extra/Gem/gem_filmQT4L.so'!


after the loading of the movie file, pd quits with the following error 
(in the terminal):

"Pixelformat not specified for video frame"
"Segmentation fault"

with the help of a linux friend i got the following error report using gdb:

warning: .dynamic section for "/lib64/ld-linux-x86-64.so.2" is not at 
the expected address (wrong library or version mismatch?)
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `/usr/local/bin/pd'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007fc9798652db in ?? () from 
[Current thread is 1 (Thread 0x7fc97698e700 (LWP 975))]
(gdb) bt
#0  0x00007fc9798652db in ?? () from 
#1  0x00007fc979ab4be6 in gem::plugins::filmGMERLIN::getFrame 
(this=0x564cc36a7970) at filmGMERLIN.cpp:270
#2  0x00007fc98f32ea8d in pix_film::grabThread (you=0x564cc36a73f0) at 
#3  0x00007fc990f4e494 in start_thread (arg=0x7fc97698e700) at 
#4  0x00007fc98f9afaff in lseek64 () at 
#5  0x0000000000000000 in ?? ()
(gdb) quit


so it seems that "libgmerlin" is the cause of the crash, right ? 
anything that can be done here ? as i said, both files loaded fine in 
windows and OSX



More information about the Pd-list mailing list