[PD] Tcl 8.4 /8.5 on mac-ppc

rolfm at dds.nl rolfm at dds.nl
Tue May 15 21:44:59 CEST 2018

> From: sebfumaster at aol.com
> To: rolfm at dds.nl, pd-list at lists.iem.at
> Subject: Re: [PD] Tcl 8.4 /8.5 on mac-ppc
> Message-ID: <16361798739-179d-410e at webjas-vad222.srv.aolmail.net>
> Content-Type: text/plain; charset="utf-8"
> I don't know the specifics but you could use the ox-app.sh script in
> the mac directory of the the source tree after building pd.
> e.g. osx-app.sh --tk 8.5.19 as the help option -h shows. (so just cd
> to the /mac directory and run the script)

great hint. very clear explanation what should be possible.
however, it didn't work because of problems with SSL certificates,
for which i  don't have a solution.
(the output is at the end of this mail)


>> -should it then be necessary/possible to compile Pd with this Tcl 8.5
> the good thing is, you don't need to compile Pd with Tcl/Tk *at all*.
> Wish (the Tcl/Tk interpreter), is a standalone program that is started
> by Pd and interprets Pd's tcl/tk commands.
> you should be able to replace the embedded Wish implementation by a
> newer version.

i had a look at that.
the Pd-tree of the 'regular' mac version differs from the ppc one.
it has a "frameworks" folder (with Tcl in it) that's not in the ppc one.

furthermore, it's unclear for me what exactly is part of the embedded 
Wish implementation.
i tried replacing the whole tcl folder, to no avail.

> btw, you could also consider installing Debian on your ppc to get newer
> software.

nice try.
my cooperation is with other people with old and new macs,
for whom Linux is out of the question.

> i don't remember the details, but maybe kiosk-plugin doesn't *really*
> require tcl/tk 8.5 (and just assumes it does).
> you could try removing the version from kiosk-plugin.tcl:9 (so it only
> reads `package require Tcl`), and see whether it bites back.

i did that already. it bites back.



maccie:mac rolfmeesters$ ./osx-app.sh --tk 8.5.19 0.48-1
Using custom 8.5.19 Wish.app
==== Creating Tcl/Tk Wish-8.5.19.app
   % Total    % Received % Xferd  Average Speed   Time    Time     Time  
                                  Dload  Upload   Total   Spent    Left  
100   345  100   345    0     0     21      0  0:00:16  0:00:15  0:00:01 
curl: (60) SSL certificate problem, verify that the CA cert is OK. 
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate 
verify failed
More details here: http://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a "bundle"
  of Certificate Authority (CA) public keys (CA certs). The default
  bundle is named curl-ca-bundle.crt; you can specify an alternate file
  using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
  the bundle, the certificate verification probably failed due to a
  problem with the certificate (it might be expired, or the name might
  not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
  the -k (or --insecure) option.

(i tried the suggestion of 'curl -insecure' but i needs an URL which i 
don't know)

More information about the Pd-list mailing list