[PD] MIDI timing FIFO overflowed receiving sysex (pt.2)

mario buoninfante mario.buoninfante at gmail.com
Sun Jun 17 00:08:19 CEST 2018

Hi Dan,

the last patch I tried has only a [midiin] connected to a counter made 
with Pd objects in Vanilla, so that I could count the number of incoming 
messages. Unfortunately I cannot give you (at least at the moment) the 
sysex file, since is sent by a piece of hardware. my sneaky suspicious 
is that the issue is "rate related". It looks to me like Pd tries to 
keep up but without any success.

another thing that pops up in my mind is the sysex length. in my case 
the messages are 256 bytes long, do we have any restriction in Pd?

anyway I'll try to capture the sysex using a different tool and send it 
over to you.



On 16/06/18 23:00, Dan Wilcox wrote:
> a couple things:
> * Do you have a patch or set up that causes this?
> * Does it happen only based on a certain length or does it only happen 
> to a certain message?
> * Can you send me the raw byte values for the message?
>> On Jun 16, 2018, at 9:02 AM, pd-list-request at lists.iem.at 
>> <mailto:pd-list-request at lists.iem.at> wrote:
>> From: Mario Buoninfante <mario.buoninfante at gmail.com 
>> <mailto:mario.buoninfante at gmail.com>>
>> To: pd-list <pd-list at lists.iem.at <mailto:pd-list at lists.iem.at>>
>> Subject: [PD] MIDI timing FIFO overflowed receiving sysex (pt.2)
>> Message-ID:
>> <CAHs=M8RCrCw5t1EO9iS_BKVL3J=6SnRhejxiWxvbWfVwsyU4Ng at mail.gmail.com 
>> <mailto:CAHs=M8RCrCw5t1EO9iS_BKVL3J=6SnRhejxiWxvbWfVwsyU4Ng at mail.gmail.com>>
>> Content-Type: text/plain; charset="utf-8"
>> Hi,
>> few months ago I was writing about some issues sending big sysex to Pd.
>> Miller suggested the following
>> *If you don't mind recompiling Pd, you can control the MIDI queue size
>> *>* by editing this line in s_midi.c:
>> *> >* #define MIDIQSIZE 1024
>> *> >* I think it has to be a power of 2.  You could make it 0x100000,
>> for instance
>> *>* (a million-ish).
>> *> >* To easily recompile Pd on a Mac, install the developer package 
>> (compiler
>> *>* chain which I think is now called Xcode), open a shell, Cd to
>> *>* Pd-x.app/Contents/Resources/src, edit s_midi.c, and type "make".
>> *>
>> I tried recompiling both on Linux (Ubuntu Studio 16.04) and MacOS 
>> (Sierra)
>> but unfortunately without any success. I mean, I've been able to 
>> recompile
>> it, but the issue's still there. moreover I couldn't find s_midi.c in
>> *Pd-x.app/Contents/Resources/src*
>> so I had to use the source code.
>> basically I'm sending (relatively) big sysex to Pd as fast as 
>> possible and
>> I noticed Pd drops most of them. I'm collecting few hundreds byte on 
>> top of
>> thousands.
>> did I miss something?
>> does anyone experienced something like that? any suggestion?
>> cheers,
>> Mario
> --------
> Dan Wilcox
> @danomatika <http://twitter.com/danomatika>
> danomatika.com <http://danomatika.com>
> robotcowboy.com <http://robotcowboy.com>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20180616/ed9e71f4/attachment-0001.html>

More information about the Pd-list mailing list