[PD] Loading tclpd on Ubuntu Bionic

IOhannes m zmoelnig zmoelnig at iem.at
Mon Jul 9 12:04:20 CEST 2018

TL;DR: there's a bug in Pd's development files for which i've submitted
a fix.

On 2018-07-08 21:11, Kaj Ailomaa wrote:
> No, sorry.  I missed the last part of the console output saying 'tclpd: can't load library'.
> Further up it did say 'tried /path/to/tclpd.pd_linux and succeeded', so the file is in deed found.

raise the verbosity, and you might see something like:

$ pd -verbose -lib tclpd
tried /usr/lib/pd/extra/tclpd/tclpd.pd_linux and succeeded
/usr/lib/pd/extra/tclpd/tclpd.pd_linux: undefined symbol:

tclpd automatically creates a mapping between the symbols (functions,
variable names) declared in Pd's header files and the tcl scripting
unfortunately, some of the symbols Pd declares as being exported (and
thus usable by an external), are nowhere defined.
this is usually not a problem, as these symbols seem to be used by no
external developer in the world (and if they were used, the problem
would be quickly discovered).
however, tclpd is slightly different, as *all* symbols are used
automatically (due to the automated mapping).

the solution to the problem is to fix Pd's header files to only include
symbols that actually exist, and then to recompile tclpd.

i've submitted a fix for this in the "bugfixes" branch on github
(commits a449bd24..d971f8f9)

i've also updated the Debian package and uploaded it to Debian/unstable
last night (so it will be included in Ubuntu Cosmic).
a new binary of the "pd-tclpd" Debian package will be available soon.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20180709/0c3eb9e1/attachment.sig>

More information about the Pd-list mailing list