[PD] Japanese language problem

Dan Wilcox danomatika at gmail.com
Mon Aug 13 15:56:36 CEST 2018

Internationalization support is definitely high on my list. Is there some way you could get a copy of the string that causes the error? It's hard to debug/fix things without the same set up, ie. it could be a problem with Tcl/Tk or Portaudio string handling on Windows, etc. In any case, the audio dialog shouldn't crash Pd on our friends in Japan!

> On Aug 2, 2018, at 5:52 AM, S.E.P. <dreamoftheshoreofanotherworld at gmail.com> wrote:
> I guess I'll have to change my system settings to a European language then. Too bad! It was good for my vocabulary to have the JP settings. 
> On Thu, Aug 2, 2018 at 3:21 AM, Dan Wilcox <danomatika at gmail.com <mailto:danomatika at gmail.com>> wrote:
> It might then be a lower-level issue with the device strings returned by Portaudio.
>> On Aug 1, 2018, at 11:56 AM, S.E.P. <dreamoftheshoreofanotherworld at gmail.com <mailto:dreamoftheshoreofanotherworld at gmail.com>> wrote:
>> Hm, I made those changes to dialog_audio.tlc and it didn't help. After that, I tried making the pd-lang.bat file as per the github link's instructions and that also didn't work (It launches PD, but I still get the error when trying to open Audio Settings.
>> On Tue, Jul 31, 2018 at 4:41 AM, Dan Wilcox <danomatika at gmail.com <mailto:danomatika at gmail.com>> wrote:
>> Can you do a test by modifying the Audio dialog's TCL script? It's in the Pd folder: tcl/audio_dialog.tcl
>> Modify the "set audio_indev" & "set audio_outdev" lines starting at 103 from:
>>     set audio_indev1 $indev1
>> to 
>>     set audio_indev1 [encoding convertfrom $indev1]
>> This should convert the device name from the system encoding to UTF8 which the Tk GUI should be able to handle.
>> Basically, modify those lines, then save the file and (re)start Pd. If it doesn't appear or crashes right away, then there is a low-level script error. It's a good idea to make a backup of the file just in case this happens.
>> We may have to escape more strings throughout the GUI and probably re-encode the device strings when sending them back to the pd-core.
>>> On Jul 30, 2018, at 6:11 PM, Dan Wilcox <danomatika at gmail.com <mailto:danomatika at gmail.com>> wrote:
>>> It's a bug. Pd should be able to handle unicode in this case.
>>> In the meantime, you can set the LANG environment variable when starting Pd to English as detailed in https://github.com/pure-data/pure-data/blob/master/po/README.txt#L42 <https://github.com/pure-data/pure-data/blob/master/po/README.txt#L42>
>>>> Hello,
>>>> Pure Data throws the following error when I try to open up Media>Audio
>>>> Settings:
>>>> (Tcl) UNHANDLED ERROR: extra characters after close-brace
>>>> while executing
>>>> "lappend audio_indevlist {}CN (Realtek High Definition}
>>>> global audio_outdevlist; set audio_outdevlist {}
>>>> lappend audio_outdevlist {Xs [J ..."
>>>> ("uplevel" body line 2)
>>>> invoked from within
>>>> "uplevel #0 $docmds"
>>>> My OS is in Japanese and, according to this page (
>>>> https://drugscore.blog.fc2.com/blog-entry-194.html <https://drugscore.blog.fc2.com/blog-entry-194.html>), I need to change the
>>>> language setting of my OS to English (presumably other European languages
>>>> would work, since I've used PD on a German-language system) to bypass this
>>>> system.
>>>> Just wondering if there was another fix- it's not a big deal for me to
>>>> change the settings, but maybe for Japanese people interested in PD it
>>>> would be.

Dan Wilcox
@danomatika <http://twitter.com/danomatika>
danomatika.com <http://danomatika.com/>
robotcowboy.com <http://robotcowboy.com/>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20180813/fa1c1b4f/attachment-0001.html>

More information about the Pd-list mailing list