[PD] Recognizing USB MIDI interfaces on Pd 0.48.1 (Debian 9.5)

Ingo ingo at miamiwave.com
Fri Nov 30 16:47:21 CET 2018

Thanks, Jamie!

got it finally to connect or disconnect now.

I didn't have the correct client and ID numbers.
I'll have to find a way to retrieve the port number of an unknown USB 
interface first automatically before I can connect it to Pd automatically.
I couldn't find any way to connect an existing new port without knowing its 

I tried	aconnect *:0 128:0	instead of	aconnect 24:0 128:0	but it didn't work.
Obviously havin * become 128 would cause a feedback loop - so it makes sense 
not to work.

I had also installed qjackctl as IOhannes suggested.
This also works.

Thanks, IOhannes!

But I would have to figure out how to connect the ports without the graphical 
part by command lines.
I'll check both options. Aconnect seems to be the way to go for now.

Thanks everybody!
I'm on my way to have it back to the way it used to be with a few more tweaks.

Now I only have to get my write protected OS to boot up which seems to be 
different on Debian Stretch as compared to my old Ubuntu.


From: Ingo [mailto:ingo at miamiwave.com]
Sent: Thursday, November 29, 2018 11:05 PM
To: 'Jaime Oliver'
Cc: 'Pd-List'
Subject: RE: [PD] Recognizing USB MIDI interfaces on Pd 0.48.1 (Debian 9.5)

connect with any option does not connect the MIDI devices to Pd while running 

I tried aconnect -l, aconnect -i, aconnect -o, aconnect -d, aconnect -e and 
aconnect -x from Pd with [shell] and from a terminal.
I tried alsa-midi and oss-midi with or without sending the midi-dialog.

aconnect -i, aconnect -o and aconnect -l listed the USB-MIDI interface 
correctly but did not connect it.
The Pd console says:

opened 0 MIDI input device(s) and 0 output device(s)

Using OSS-MIDI nothing further happened.
Using ALSA-MIDI it crashed after alsaconnect -i and sending any midi-dialog 
like  [1 2 3 4 1 2 3 4 4 4( or  [2 3 4 5 2 3 4 5 4 4( twice.

When connecting the USB device during startup of Pd it works fine - but 
aconnect -d or -x does not disconnect it either.

I just noticed that on my machine that I used for testing Pd 0.47.1 was 
Were there any changes since 0.47.1 and 0.48.1?
I have another box with 0.48.1 installed and will try again tomorrow.


From: Jaime Oliver [mailto:jaime.oliver2 at gmail.com]
Sent: Thursday, November 29, 2018 9:26 PM
To: ingo at fixitinthemix.de
Cc: Pd-List
Subject: Re: [PD] Recognizing USB MIDI interfaces on Pd 0.48.1 (Debian 9.5)

you mean "aconnect -l" in the terminal does not give you any devices?

On Thu, Nov 29, 2018 at 3:25 PM Ingo <ingo at fixitinthemix.de> wrote:
Doesn't work here.

From: Pd-list [mailto:pd-list-bounces at lists.iem.at] On Behalf Of Jaime Oliver
Sent: Thursday, November 29, 2018 7:48 PM
To: IOhannes m zmoelnig
Cc: Pd-List
Subject: Re: [PD] Recognizing USB MIDI interfaces on Pd 0.48.1 (Debian 9.5)

You can also use alsa-midi in pd and "aconnect" to connect your device to pd
without using jack.

On Thu, Nov 29, 2018 at 1:43 PM IOhannes m zmölnig <zmoelnig at iem.at> wrote:
On 11/29/18 6:56 PM, Ingo wrote:
> Mmmhh,
> I really don't want to use jack for this.

i didn't propose anything with jack.
qjackctl (despite it's name) is a tool that allows to manage
- jack audio connections
- jack midi connections
- alsa midi connections

i was only talking about the last option, which is totally independent
of of JACK.

qjcackctl would allow you to magically connect your new devices to Pd
once they are plugged in, without having the need to open any dialog.

i don't know about OSS-MIDI. i never use it.


Pd-list at lists.iem.at mailing list
UNSUBSCRIBE and account-management ->

Jaime E Oliver LR

Jaime E Oliver LR

More information about the Pd-list mailing list