[PD] Self-compiled PD can't load Gem.dll on Windows

IOhannes m zmoelnig zmoelnig at iem.at
Mon Dec 3 09:32:48 CET 2018

On 03.12.18 02:31, oliver wrote:
> hi, dear list !
> i recently did a successful self-compiling of the latest PD sources with
> Msys2 on my Windows 7 system, following lucardas instructions (which is
> basically a shorthand of the INSTALL.txt file that comes along with the
> latest PD sources).
> everything went well - i had no errors in the compilation process and
> received a working pd-0.49.0
> i also tried external libraries, all of them were perfectly loading and
> working, save for (you guessed it by the subject): Gem
> ====================================================
> C:\\pd-0.49.0\\extra\\Gem\\Gem.dll: couldn't load
> Gem: can't load library
> ====================================================

suspect #1: are you by-chance trying to load a 32bit version of Gem into
a 64bit version of Pd? that won't work. both the host (Pd) and the
external (Gem) must have the same "architecture".

suspect #2: the usual mismatch between msvcr90.dll (missing from the Gem
distribution) and the likes. the mailinglist archives should cover this.

just for the record: i can load Gem-0.93.3 ("Windows Archive (binaries +
documentation)", so that's the ZIP version), just fine with
Pd-0.49-0-i386 (ZIP version as well), using "wine" (not having tried it
on a native windows machine)


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20181203/116b0e79/attachment.sig>

More information about the Pd-list mailing list