[PD] Self-compiled PD can't load Gem.dll on Windows

oliver oliver at klingt.org
Mon Dec 3 13:55:09 CET 2018

IOhannes m zmoelnig wrote:
> On 03.12.18 02:31, oliver wrote:
>> hi, dear list !
>> i recently did a successful self-compiling of the latest PD sources with
>> Msys2 on my Windows 7 system, following lucardas instructions (which is
>> basically a shorthand of the INSTALL.txt file that comes along with the
>> latest PD sources).
>> everything went well - i had no errors in the compilation process and
>> received a working pd-0.49.0
>> i also tried external libraries, all of them were perfectly loading and
>> working, save for (you guessed it by the subject): Gem
>> ====================================================
>> C:\\pd-0.49.0\\extra\\Gem\\Gem.dll: couldn't load
>> Gem: can't load library
>> ====================================================
> suspect #1: are you by-chance trying to load a 32bit version of Gem into
> a 64bit version of Pd? that won't work. both the host (Pd) and the
> external (Gem) must have the same "architecture".

both versions are 32bit alright

> suspect #2: the usual mismatch between msvcr90.dll (missing from the Gem
> distribution) and the likes. the mailinglist archives should cover this.

thanks, IOhannes. that was the right hint !

actually it was "pthreadVC.dll" in the BIN folder that caused the error. 
the self-compiled PD had its accompanying file "pthreadVC.lib" dated 
from 2002, whereas the .dll was from 2018. i figure here's the mismatch.

so i exchanged the new "pthreadVC.dll" with the old one from the 
official .zip package and Gem loaded and worked fine !



More information about the Pd-list mailing list