[PD] Self-compiled PD can't load Gem.dll on Windows

oliver oliver at klingt.org
Thu Dec 6 12:22:44 CET 2018

IOhannes m zmoelnig wrote:
> On 03.12.18 13:55, oliver wrote:
>> actually it was "pthreadVC.dll" in the BIN folder that caused the error.
>> the self-compiled PD had its accompanying file "pthreadVC.lib" dated
>> from 2002, whereas the .dll was from 2018. i figure here's the mismatch.
>> so i exchanged the new "pthreadVC.dll" with the old one from the
>> official .zip package and Gem loaded and worked fine !
> so which dll(s) did you remove, exchange,... exactly?
> (all this "new" and "old" and "official" kind of confuses me)

hi, sorry for the confusion ...

so, we're talking windows (7/64bit) here:

the file i had to change in order to make Gem load on a self-compiled PD 
was "pthreadVC.dll".

after succesful compilation the "bin" folder contained "pthreadVC.dll" 
with a modified date of 03.12.2018, so i figure that this .dll was 
created during the compilation process.

i exchanged this "pthreadVC.dll" with a version that has a modified date 
of 03.04.2002. this file is included in the recent puredata .zip package 
from miller's site (pd 0.49)

after that action, Gem.dll loaded and worked alright.
no other .dlls had to be changed.



More information about the Pd-list mailing list