[PD] Gem / [pix_movie] trouble: "no movie decoding backends found"

Carlos Franke carlos_franke at posteo.de
Sun Feb 10 20:50:36 CET 2019

I'm having trouble loading any video file in Gem using [pix_movie] or

I'm an absolute beginner regarding Gem and inexperienced in Pure Data,
so I'm probably making some simple mistake. Regardless, I cannot seem
to find the solution myself or on the web. (If I get it here, I'm going
to post it in the pdpatchrepo forum[1], so that it can be picked up by
search engines in the future.) 

When I create a [pix_movie] or [pix_film] object, I get the message:

   [pix_movie]: no movie decoding backends found!

Subsequently, when I try to open a video file with an [open( message,
this fails with:

   [pix_movie]: unable to open file: ../data/alea.mpg

I have tried with the bundled example videos (alea.mpg, homer.avi,
anim-1.mov) and a few others. I'm encountering this exact same error on
two very different platforms, so I'm pretty sure it's my mistake and
not a bug: In one case on a Raspberry Pi 3 B running DietPi as an
operating system, Pd 0.47.1 and Gem 0.93.3 installed as a Raspbian
package. In the other case on my laptop running Arch Linux, with Pd
0.49.0 installed from the Arch repos and Gem 0.87 installed via deken.

Apart from loading videos, Gem appears to be working fine in both



More information about the Pd-list mailing list