[PD] help loading pix_opencv

Fede Camara Halac camarafede at gmail.com
Fri Mar 1 02:00:43 CET 2019

ok. i think you can discard my last email. It turns out i was loading the old 32bit i had.  my bad. 


i did some more digging and the reason pd does not load the externals is that they dont exist. somehow the only object built is pix_opencv.pd_darwin, which just fires a console welcome message. The rest of the pix_opencv_*.pd_darwin objects are not created. Only their *.o are there and they *can* be used to make their respective ps_darwins (tried with one and worked, loaded and all :)

First, I dont know why this last step of the linking is just not happening. How can I make sure this is not something missing from the generated Makefile?

Second, I dont fully understand these makefiles. Can this all be done easier with pd-lib-builder? I am tempted to try and do something like that.

thanks for your help!!


> On Mar 1, 2019, at 12:48 AM, Federico Camara Halac <camarafede at gmail.com> wrote:
> I removed yet another object from src/Makefile.am (the one calling '_cvCalcGlobalOrientation')
> but now, I get "no suitable image found", and "mach-o, but wrong architecture"
> /Users/federicocamarahalac/Documents/Pd/externals/Gem/../pix_opencv/pix_opencv_hough_circles.pd_darwin: dlopen(/Users/federicocamarahalac/Documents/Pd/externals/Gem/../pix_opencv/pix_opencv_hough_circles.pd_darwin, 10): no suitable image found.  Did find:
> 	/Users/federicocamarahalac/Documents/Pd/externals/Gem/../pix_opencv/pix_opencv_hough_circles.pd_darwin: mach-o, but wrong architecture
> 	/Users/federicocamarahalac/Documents/Pd/externals/pix_opencv/pix_opencv_hough_circles.pd_darwin: mach-o, but wrong architecture
>> On Thu, Feb 28, 2019 at 11:50 PM Federico Camara Halac <camarafede at gmail.com> wrote:
>> Thanks!
>> To follow up, I *think* I am linking all I can, this is from console.log:
>> ...
>> LIBS='-lopencv_video -lopencv_calib3d -lopencv_objdetect -lopencv_imgproc '
>> ...
>> OPENCV_LIBS='-L/usr/local/lib -lopencv_dnn -lopencv_ml -lopencv_objdetect -lopencv_shape -lopencv_stitching -lopencv_superres -lopencv_videostab -lopencv_calib3d -lopencv_features2d -lopencv_highgui -lopencv_videoio -lopencv_imgcodecs -lopencv_video -lopencv_photo -lopencv_imgproc -lopencv_flann -lopencv_core'
>> ...
>> So, if i'm not underlinking, is there a way for me to see if its actually a header/library mismatch? There are no complains when it's compiling.
>>> On Thu, Feb 28, 2019 at 11:14 PM IOhannes m zmölnig <zmoelnig at iem.at> wrote:
>>> On 2/28/19 9:30 PM, Federico Camara Halac wrote:
>>> > 10): Symbol not found: _cvCalcGlobalOrientation
>>> >   Referenced from:
>>> so you are underlinking, that is, not linking against a required OpenCV
>>> library.
>>> apart from the obvious reason (forgotten to link against the proper
>>> libs), there are other causes for this, like using a mismatched
>>> header/library combination.
>>> gfmrdsa
>>> IOhannes
>>> _______________________________________________
>>> Pd-list at lists.iem.at mailing list
>>> UNSUBSCRIBE and account-management -> https://lists.puredata.info/listinfo/pd-list
>> -- 
>> http://fdch.github.io/tv
> -- 
> http://fdch.github.io/tv
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20190301/11a3039b/attachment-0001.html>

More information about the Pd-list mailing list