[PD] Installing libraries/externals via terminal or using -nogui

Joey Dodson joey.dodson3 at gmail.com
Thu Jun 13 11:04:37 CEST 2019


I had tk installed, so that was not the issue with X11 forwarding. I tested
some other programs, like xterm and they also had issues, which I was able
to track down to needing to set X11UseLocalhost no on the Rpi. I am now
able to get X11 forwarding for xterm, but it's still not working for Pd.
Here are the errors I'm getting:

$ pd -lib zexy -open testaudio.pd
X Error of failed request:  BadAccess (attempt to access private resource
  Major opcode of failed request:  18 (X_ChangeProperty)
  Serial number of failed request:  12
  Current serial number in output stream:  15

I thought it was permissions related, so I tried:

$ sudo pd -lib zexy -open testaudio.pd
X11 connection rejected because of wrong authentication.
X11 connection rejected because of wrong authentication.
application-specific initialization failed: couldn't connect to display

On Wed, Jun 5, 2019 at 7:11 AM Joey Dodson <joey.dodson3 at gmail.com> wrote:

> Lucas, I will check into that. Thanks for the suggestion!
> On Sat, Jun 1, 2019, 9:30 AM Lucas Cordiviola <lucarda27 at hotmail.com>
> wrote:
>> Could it be that those errors on the GUI are because you have no tcl/tk
>> installed?
>> Try:
>>      sudo apt-get install tk
>> Then start a normal Pd with GUI.
>> Mensaje telepatico asistido por maquinas.
>> On 6/1/2019 5:00 AM, Joey Dodson wrote:
>> > I've tried starting it with the gui, since I'm theoretically using X11
>> > forwarding, but I'm getting errors and Pd won't start with the gui on
>> > my Pi. Since I didn't find any obvious solution for those errors, I
>> > prefer to stick with the terminal for now.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20190613/061c51f6/attachment-0001.html>

More information about the Pd-list mailing list