[PD] Installing libraries/externals via terminal or using -nogui

Joey Dodson joey.dodson3 at gmail.com
Thu Jun 13 11:09:25 CEST 2019


I did manage to install the deken command line tool, however I've not been
able to figure out how to install anything with it. The most I could do was
$ deken find
to see that it does list else as follows:

else/1.0beta20 uploaded by porres on 2019-06-11 22:20:32 for Linux-armv7-32

I haven't had any luck figuring out what to do next. The documentation for
the command line tool seems a bit lacking as it doesn't have much
information via $ deken -h nor $ man deken nor in the README files on
github. If anyone can point me in the right direction, I'd be really

On Thu, Jun 13, 2019 at 2:04 AM Joey Dodson <joey.dodson3 at gmail.com> wrote:

> Lucas,
> I had tk installed, so that was not the issue with X11 forwarding. I
> tested some other programs, like xterm and they also had issues, which I
> was able to track down to needing to set X11UseLocalhost no on the Rpi. I
> am now able to get X11 forwarding for xterm, but it's still not working for
> Pd. Here are the errors I'm getting:
> $ pd -lib zexy -open testaudio.pd
> X Error of failed request:  BadAccess (attempt to access private resource
> denied)
>   Major opcode of failed request:  18 (X_ChangeProperty)
>   Serial number of failed request:  12
>   Current serial number in output stream:  15
> I thought it was permissions related, so I tried:
> $ sudo pd -lib zexy -open testaudio.pd
> X11 connection rejected because of wrong authentication.
> X11 connection rejected because of wrong authentication.
> application-specific initialization failed: couldn't connect to display
> "raspberrypi:10.0"
> On Wed, Jun 5, 2019 at 7:11 AM Joey Dodson <joey.dodson3 at gmail.com> wrote:
>> Lucas, I will check into that. Thanks for the suggestion!
>> On Sat, Jun 1, 2019, 9:30 AM Lucas Cordiviola <lucarda27 at hotmail.com>
>> wrote:
>>> Could it be that those errors on the GUI are because you have no tcl/tk
>>> installed?
>>> Try:
>>>      sudo apt-get install tk
>>> Then start a normal Pd with GUI.
>>> Mensaje telepatico asistido por maquinas.
>>> On 6/1/2019 5:00 AM, Joey Dodson wrote:
>>> > I've tried starting it with the gui, since I'm theoretically using X11
>>> > forwarding, but I'm getting errors and Pd won't start with the gui on
>>> > my Pi. Since I didn't find any obvious solution for those errors, I
>>> > prefer to stick with the terminal for now.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20190613/25d64b09/attachment.html>

More information about the Pd-list mailing list