[PD] Issue with PD .50.0 + Windows Driver?

Rick Snow ricksnow at gmail.com
Mon Jan 6 19:17:18 CET 2020

Hello list,

I wonder if someone here can give me some advice..  I am in a situation where I need to run PD in coordination with Processing on a high end windows machine running Windows 10.  Everything worked perfectly until this morning.  Now PD’s audio is not working at all.  Audio from a web browser works fine.  Audio from Audacity works fine although I don’t see any options for an input audio device (not that I have one plugged in).

When I open PD and run test audio midi I get this error message:
“error opening audio: Illegal combination of I/O devices”

When I open Audio settings, I have:
input: ASIO: Realtek ASIO
output: MMIO:Speakers (Realtek(R) Audio)

There are no other input device options.

For output I have these options:
MMIO:Microsoft Sound Mapper - Output
MMIO:Speakers (Realtek(R) Audio)
MMIO:PHL 276E8V (2-NVIDIA High Defi
MMIO: Digital Audio (S/PDIF) (Realtek

If I turn off the input device (uncheck) I am able to get a very distorted test tone.

This problem seems to have started soon after I tried changing my screen resolution and then changing the pd font size and stretch options. I don’t know if this had anything to do with the problem or not though.

I have tried reinstalling PD a couple times and reinstalling the Realtek drivers.

Thanks for any advice.


More information about the Pd-list mailing list