[PD] Py/pyext not recognized...

Raphael Raccuia rafael.raccuia at blindekinder.com
Mon May 11 00:21:33 CEST 2020

Hi Johannes, thank you,

Le 10.05.20 à 20:56, IOhannes m zmölnig a écrit :
> On 5/10/20 12:52 AM, Raphael Raccuia wrote:
>> Hi list,
>> I cant't make it working. I use PD 0.48 and
>> 0.50 on another system, I tried to install from Ubuntu/Mint
>> repositories, then with Deken, but still "couldn't create..."
> how do you try to load them?
I tried with [import] (seems to be deprecated), [declare], /path/ 
settings, /startup/ settings (/py/ in /flags/): all says :/py: can't 
load library/
> run Pd with "-verbose" and see what you get (where the external is
> searched for). watch the Pd-console for errors. watch the terminal for
> errors.
well, with _-verbose_ checked in path window, a long list of paths 
/failed/, and two /succeeded/, but with message:
//usr/lib/pd/extra/py/py.pd_linux: /usr/lib/pd/extra/py/py.pd_linux: 
undefined symbol: _ZTI17flext_base_shared/
and bellow:
//usr/lib/pd/extra/py/py.pd_linux: /usr/lib/pd/extra/py/py.pd_linux: 
undefined symbol: _ZTI17flext_base_shared/
> i wouldn't trust the deken package to work correctly for a binary with
> complex dependencies such as python.
> using the Debian package "pd-py" (which is what you get when installing
> from Ubuntu/Mint repositories), the [py] object instantiates just fine:
yes, it's what I use
> ~~~
> ------------------------------------------------
> py/pyext 0.2.2 - python script objects
> (C)2002-2015 Thomas Grill - http://grrrr.org/ext
> using Python 2.7.18 (default, Apr 20 2020, 20:30:41)
> [GCC 9.3.0]
> Python array support enabled
> ----------------------------------------------
> ~~~
> since you seem to be using "Pd 0.48 and Pd-0.50" on Mint, i guess you
> have compiled Pd yourself and it's either installed into /usr/local/ or
> not at all.
no compilation, 0.48.1 comes from Mint 19 repos, and 0.50 from 
Kubuntu/KXStudio repos.
> in this case your self-compiled Pd will not automatically search in the
> paths where the Debian packages installs the external to: so you should
> add "/usr/lib/pd/extra" to your search-paths.
>> Is py/pyext still usable?
> well, py/pyext as released is Python2.7 only, and Python2.7 has seen EOL
> a couple of months ago.
> there has been some work towards making it work with Python3, but
> nothing has been released yet.
wow, I didn't noticed that. I hope I can use matPlotLib with 2.7.
Thank you!
> fgmasd
> IOhannes
> _______________________________________________
> Pd-list at lists.iem.at mailing list
> UNSUBSCRIBE and account-management -> https://lists.puredata.info/listinfo/pd-list

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20200511/99f51bc1/attachment.html>

More information about the Pd-list mailing list