[PD] loading externals on Debian (was Re: Py/pyext not recognized...)

Jakob Laue jakkesprinter at web.de
Mon May 18 22:22:01 CEST 2020

Hey IOhannes,
sorry for stumpling in here. If it is not okay, I will open a new thread.
I have a question regarding your statement '[declare -path XY]'.
I have trouble loading the mrpeach-library on startup and mrpeach comes with multiple binaries (at least here on my mac, downloaded from deken). 
I tried "-path /path/To/MrPeach" in the command line preferences and I also specified the path to mrpeach in the search path preferences. When I have both of the latter, in a new patch I can create e.g. [midifile] and it works. But when I add a "-lib mrpeach" in the command line preferences, I always get "mrpeach: can't load library" on startup. But I can still create objects from it. I mean, I can use the objects, but I don't get an overall init-message on startup, which makes me think that someting is not set correctly. Also, pd seems not to be able to find the help files for mrpeach-objects. Right-clicking [midifile] and selecting "help" gives "sorry, couldn't find help patch for "midifile-help.pd"" in the console.

Do you have an idea what I could try to do? 
Thank you, 

PS. Your user name is the best! :-D  


Gesendet: Dienstag, 12. Mai 2020 um 12:47 Uhr
Von: "IOhannes m zmölnig" <zmoelnig at iem.at>
An: pd-list at lists.iem.at
Betreff: [PD] loading externals on Debian (was Re: Py/pyext not recognized...)
On 5/12/20 11:16 AM, Raphael Raccuia wrote:
> well,
> thank you anyway...
> I tried matPlotLib with Python 2.7, my script doesn't work, at least as
> it is.
> So maybe it's easier to wait pd-py for Python3.
> If you have any idea how to bind Pd to that script, it's welcome. I'll
> try something simple with [shell].
> By the way, I'm confused on the way to load externals, since there are
> not loaded after Ubuntu packages install

that's by design.
installing a program doesn't automatically run it.
installing an external doesn't automatically load it.

> : I tried with [declare], but
> often it doesn't find libs, probably a path issue, since PD never
> searches in the right directory (seen with path verbose). It seems the
> path is relative to the patch, or to PD (-std...). For example with
> _ggee_, I had to add the absolute path in the settings.
> Are deb packages supposed to configure that?

they are supposed to just work (and generally do).

there are two issues why it doesn't work for you:
- some libraries come with a single-binary that contains multiple
objects (e.g. zexy), other libraries put one binary for each object into
a directory (e.g. bsaylor). they need to be loaded differently. e.g.
[declare -lib zexy] vs [declare -path bsaylor]. in the latter case
(multiple binaries in a directory) you could also instantiate objects
directly with a name prefix e.g. [bsaylor/partconv~]
- older versions of Pd would omit the standard paths (e.g.
"/usr/lib/pd/extra") when searching for paths declared with [declare -path].


PS: rather than adding a "btw", why not just start a new thread, with a
new subject?

Pd-list at lists.iem.at mailing list
UNSUBSCRIBE and account-management -> https://lists.puredata.info/listinfo/pd-list

More information about the Pd-list mailing list