[PD] Installing GEM through Dekken not working

mick mengucci misturapura at gmail.com
Thu Sep 10 15:31:09 CEST 2020

Hi list, I have problems instaling GEM, I hope somebody is willing to point
me in the right direction. Here is what I did.

I installed Pd 0.48.1 with the terminal

*sudo apt-get install puredata*

That worked fine, I am on Xubuntu 18. Typing in terminal:

*lsb_release -a *


*No LSB modules are available.*

*Distributor ID: Ubuntu*

*Description: Ubuntu 18.04.5 LTS*

*Release: 18.04*

*Codename: bionic*

My processor info, typing in terminal:


I get:

*Architecture: x86_64*

*CPU op-mode(s): 32-bit, 64-bit*

*Byte Order: Little Endian*

*CPU(s): 2*

*On-line CPU(s) list: 0,1*

*Thread(s) per core: 1*

*Core(s) per socket: 2*

*Socket(s): 1*

*NUMA node(s): 1*

*Vendor ID: AuthenticAMD*

*CPU family: 21*

*Model: 112*

*Model name: AMD A6-9225 RADEON R4, 5 COMPUTE CORES 2C+3G*

So I assume it is an AMD type.

Then I wanted to install the GEM graphical environment with dekken.

Typing *gem *in the dekken window gives many choices. To figure out which
one to install I look for the processor type and OS type. So in my case I
first tried with version 5.0, that did not work, here is the error:

*Commencing downloading of:*


*Into /home/mick/Documents/Pd/externals...*

*Successfully unzipped deken-plugin-v0.5.0--externals.zip into

*Unable to add %s to search paths*

Then I exit the process and got these details in the error message:

*invalid command name ".externals_searchui.results"*

*invalid command name ".externals_searchui.results"*

*while executing*

*"$mytoplevelref.results delete 1.0 end"*

*(procedure "::deken::clearpost" line 3)*

*invoked from within*


*(procedure "::deken::initiate_search" line 15)*

*invoked from within*

*"::deken::initiate_search .externals_searchui"*

*invoked from within*

*".externals_searchui.searchbit.button invoke"*

*("uplevel" body line 1)*

*invoked from within*

*"uplevel #0 [list $w invoke]"*

*(procedure "tk::ButtonUp" line 22)*

*invoked from within*

*"tk::ButtonUp .externals_searchui.searchbit.button"*

*(command bound to event)*

Then tried this version:

*deken-plugin/0.3.1 (Deken externals downloader - MINIMUM VERSION REQUIRED

* Uploaded by zmoelnig @ 2018-04-05 12:00:26*

and I got the same result. Then I tried:


* Uploaded by chr15m @ 2015-08-07 14:36:01*

it did not give errors so I assumed it installed correctly but when I open
the object gemwin it gives me lots of errors, like:


*... couldn't create*

*GLdefine GL_LINEAR*

*... couldn't create*

*GLdefine GL_EXP*

*... couldn't create*


After that, when I typed gem in dekken I get 3 other options, the one that
I have “installed” (?) and two that were not there before.


* Uploaded by fjkraan @ 2019-12-28 12:07:55*

What should I try next?
Thanks for your patience and generosity.


pure mixture vibration since 1995
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20200910/355a684e/attachment.html>

More information about the Pd-list mailing list