[PD] Patch won't open

Alexandros adrcki at gmail.com
Wed Nov 9 21:30:32 CET 2022

I'm developing an external based on someone else's code, and there's a 
spot that causes a crash when freeing some memory, so I disabled that 
temporarily to check some output. I also added a t_atom pointer which I 
allocate before I call the function I mention here with getbytes(), and 
after I set some values to it and output it as a list from the first 
outlet of the object, I free the memory of the t_atom with freebytes().

At first it worked find and I got a list out the outlet, but when I 
tried to launch Pd again with this patch, Pd launches but the patch 
won't open. I tried to open the patch manually but again it doesn't 
open. Other patches open and work fine. I don't think the patch is at 
some place beyond my monitor, because I don't see any tab on the top 
part of my screen. When I open any other patch, a new tab appears there, 
next to the tab of Pd's console.

I'm on UbuntuStudio 22.04, with Pd-0.52.2. Any ideas?

More information about the Pd-list mailing list