[GEM-dev] Offscreen naming poll!
ben at ekran.org
Wed Nov 30 19:40:20 CET 2005
> B. Bogart wrote:
>> gembuffer ?
>> gembuf? (gemwin)
>> james tittle wrote:
>>> name it, and where it should go in the folder hierarchy? Currently
>>> it's named [gemframebuffer], but really I think [gemoffscreen] would
> as you state correctly, the name [gembuffer] would be coherent with the
> name [gemwindow], so the functionality should be coherent too. (imo, the
> same goes for [gemframebuffer] and [gemoffscreen].)
> i foresee nameclashes with the multiple_windows (whenever they will
>>> ...also, on my harddrive I put it in src/controls (it would be
>>> into a gemchain after [gemhead]), but I guess it could also go in
>>> src/manips, or even src/Nongeos?
> could it be an option to make an alternative(!) [gemhead] out of this
> so people could decide whether an entire gemchain is onscreen
> ([gemhead]) or offscreen ([???]).
> if so, i would vote for something really clumsy like [gemhead_os]
> ("clumsy" since i cannot think of a better name, not because the object
> _should_ be named clumsy of course)
How about putting that functionality into gemhead:
[gemhead 1] (render pri 1, onscreen)
[gemhead 1 mybuffer] (pri 1, render to buffer named mybuffer)
Could be easy to test debugging by removing the one argument (or setting
Actually this (ui wise) would work for multiple windows too,
[gemhead 1 mywindow] Then its transparent to the user if its a named
window [gemwin 30 mywindow] or a named buffer....
Just thinking aloud.
> GEM-dev mailing list
> GEM-dev at iem.at
More information about the GEM-dev